Brand New 2008 Sportsman Throttle Issue - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 04-27-2009, 06:09 AM Thread Starter
 
ss383nova's Avatar
 
Join Date: Apr 2009
Posts: 8
Brand New 2008 Sportsman Throttle Issue

I have a issue with the throttle sticking at about 3000 rpm, it's on a 2008 Sportsman with 0 miles on it. It does have .4 hours from setup. I'll take it into the dealership later today, and hopefully they will be able to look at it right away. I'm hoping to leave for a trip tomorrow. Has anyone had this same issue? It makes me a little apprehensive taking a long trip and then find out there's more stuff wrong with this thing...

Thanks

Steve G.
ss383nova is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 04-28-2009, 09:35 AM
 
clutchman's Avatar
 
Join Date: Mar 2009
Posts: 54
sounds like the thumb lever or cable issue
clutchman is offline  
post #3 of 10 (permalink) Old 04-28-2009, 12:56 PM
Administrator
 
Admin's Avatar
 
Join Date: Nov 2008
Posts: 160
Garage
Be sure to let us know what the problem was!
Admin is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 04-29-2009, 08:51 AM Thread Starter
 
ss383nova's Avatar
 
Join Date: Apr 2009
Posts: 8
The first dealership I took the quad to didn't want to do anything to it because they said it was a setup issue and that Polaris wouldn't pay him to look at it. My original dealer had told me that any Polaris dealer would warranty the bike, so I was a little unsettled by that information. But the second dealer was very much more helpful, and has the bike now. It does look like when the winch was installed, something might have interfered with the throttle cable. If you move the cable or turn the handlebars too far right now, the engine rev's higher. The new dealership is going to go thru the entire setup and let me know anything else is amiss.
If there's anything else that comes up I'll post it later.
Thanks
Steve G.
ss383nova is offline  
post #5 of 10 (permalink) Old 04-29-2009, 12:06 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Thats interesting!



Bruce! is offline  
post #6 of 10 (permalink) Old 04-30-2009, 10:48 AM Thread Starter
 
ss383nova's Avatar
 
Join Date: Apr 2009
Posts: 8
I just got a call from the dealership. They found that the throttle body is sticking and have ordered a replacement. Polaris is taking care of that. They are also taking care of a tail light issue. It had water inside the lens. All in all, these people have been great. But that first dealership won't be getting any of my business anytime soon.

Thanks
Steve G.
ss383nova is offline  
post #7 of 10 (permalink) Old 04-30-2009, 03:19 PM
 
clutchman's Avatar
 
Join Date: Mar 2009
Posts: 54
cool

you know,every time i hit a dealership i leave wanting to kill someone. i think most of them think the public are a bunch of fools when in fact they are the fools. thats why i buy online and could care less if they ever sell a part. iv been riding for 34 years and raced too. even at the races they act like they are too good to help you. i will never buy a new machine,i will wait and get one from a honest working man. its a shame we have to put up with people like that. we are the only reason they have the easy and laid back job they do. glad you found a real man to help you out. ride safe and have fun.
clutchman is offline  
post #8 of 10 (permalink) Old 05-04-2009, 10:23 AM
 
Wildhorse800's Avatar
 
Join Date: May 2009
Posts: 20
Angry

I was gonna guess the butterflies were sticking.

I agree with clutch.

I don't even want an extended warranty as I don't trust ANY dealership.

Just too many bad ones making the good ones seem obsolete.

Hence the term "STEALership"
Wildhorse800 is offline  
post #9 of 10 (permalink) Old 05-13-2009, 08:01 AM Thread Starter
 
ss383nova's Avatar
 
Join Date: Apr 2009
Posts: 8
Just wanted to let everyone know, I got the quad back from the dealership and it appears they've fixed it. They replaced the Throttle body and went thru the setup again. They replaced a leaking taillight and all seems right now. But what a fiasco. I hope I don't have to go back. Thanks to everyone for all the comments!
And so far this thing is running great. I never imagined it would have so much torque. I hauled a ton of rocks with it last weekend...

Sg.
ss383nova is offline  
post #10 of 10 (permalink) Old 05-13-2009, 12:34 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Glad to hear that! Now go ride!




I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Service manuals cookies ATV Repair and Maintenance 1119 09-10-2019 08:47 AM
Clutch Trevor Goodrum ATV Performance Modifications 4 09-13-2018 01:43 PM
02 500 6x6 thumb throttle NYrancher ATV Repair and Maintenance 2 01-30-2018 07:05 AM
hilliard clutch dbweathe ATV Repair and Maintenance 2 12-27-2017 07:28 AM
Wheel bearing brands DAKOTAKIDD Polaris Sportsman 19 03-17-2017 09:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome