Problems with my 03 Polaris Predator 500 - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-27-2009, 05:10 AM Thread Starter
 
sherrick1's Avatar
 
Join Date: Dec 2009
Posts: 2
I need Help

Hi I have 3 Problems with my 03 Polaris Predator 500

(1) I had a leak coming from the right bottom hose going to the motor so I replaced the hose and put back a new 50/50 mix (wich I hope will be fine) I put in a quart and then checked it and found that some whent in to the overflow tank.
Is that all that the bike holds is a quart?

(2)Next I put a new battery/spark plug/and cleaned and oiled air fillter and I found (when looking at the battery)to the left of the positive wire there is a black (what looks like a ground) wire and im not sure where it go's or what its for.
Can some one tell me what thats for and where it hooks back up?

(3) I just put a new battery in and it will start right up with no problems the idel was a littel rich so I got it to idel right well now if u let it idel for about 3 to 4 mins it will start to die out or stall and its hard to start back up if I let it set and cool down its fine it will start right up but then about 3 to 4 mins it will stall I dont want to go out and ride it till I get that right.
can or has any one had this problem and what can I do to fix it?

Last edited by sherrick1; 12-28-2009 at 04:59 AM.
sherrick1 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-27-2009, 07:14 AM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
First off, welcome to the board!




I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
March 2018 - Polaris ATV of the Month Voting! Wreckless ATV of the Month 5 03-29-2018 01:25 PM
Polaris passes Milestone flyinghigh ATV General Discussion 10 08-07-2017 11:25 AM
Polaris Industries Just Hit a New Milestone, And It's Not a Good One aknawful ATV General Discussion 2 08-05-2017 05:20 AM
polaris 570 2015 exhaut heating gab570 Polaris Sportsman 2 05-19-2017 10:58 AM
Welcome to the new Polaris ATV Forum! dascrow Polaris ATV News 2 09-20-2010 01:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome