rough running - limiter problems? - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-05-2009, 04:33 AM Thread Starter
 
Pennstatehoss's Avatar
 
Join Date: May 2009
Posts: 1
rough running - limiter problems?

I have a '97 Polaris Magnum 425. Over the past couple times out, it will generally run fine until I hit a puddle a certain way. Something gets wet and then the reverse limiter starts working in forward gear. I have to hold the override button in to get the engine to run normal.

I cannot find the source of this problem. Anyone have any suggestions?
Pennstatehoss is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-05-2009, 05:21 AM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
I haven't heard of that one before!




I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Polaris 500 EFI X2 Running Rough and Stalling Kiljoy ATV General Discussion 0 08-25-2018 11:47 AM
13 Sportsman running rough DanielP Polaris Sportsman 5 07-19-2018 10:47 AM
2011 800 EFI running rough tool13x ATV Repair and Maintenance 0 06-04-2017 07:43 PM
Rough Running 2004 Sportsman 400? apbaseball ATV Repair and Maintenance 2 09-15-2016 12:13 PM
Polaris Sportsman 500 6x6 running rough when warmed up cruiser83 ATV Repair and Maintenance 10 04-12-2016 07:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome