2009 sp 90 won't turn over if brake is on - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-29-2012, 03:28 PM Thread Starter
Junior Member
 
rghanlin's Avatar
 
Join Date: Apr 2012
Location: Ohio USA
Posts: 6
2009 sp 90 won't turn over if brake is on

The 90 will turn over but not fire when brake is off,when applied it won't do anything. Brake light works but nothing else. Checked all connections and wires don't know where to go next.
rghanlin is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-29-2012, 07:55 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Welcome to the board!



Bruce! is offline  
post #3 of 5 (permalink) Old 04-30-2012, 07:56 AM Thread Starter
Junior Member
 
rghanlin's Avatar
 
Join Date: Apr 2012
Location: Ohio USA
Posts: 6
Thanks Bruce! Hope I can figure this out before my Grandson come back.
rghanlin is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-30-2012, 11:18 PM
Polaris ATV Junkie!
 
AKStew's Avatar
 
Join Date: May 2010
Location: Westerville, Ohio
Posts: 919
I used to own a 2010 Sportsman 90. If I remember correctly, the brake lever had to be pulled for the starter to engage. Is it possible the starter engagement wire(s) that pass through the brake switch got reversed somehow? Or somehow crossed with the kill switch? Also make sure the throttle cable is adjusted to where the end of the lever moves only 1/16" to 1/8" when at idle.

I have to ask since I've done it before. Is the fuel petcock in the ON or RES position?

Stew

2011 Sportsman 500 HO Touring: Polaris 3500 lb. Winch, Kimpex Adventure XL Trunk, 7" Passenger Foot Risers, UNI Foam Filter
2006 Sportsman 500 X2 EFI: Superwinch Terra 25 w/Synthetic Rope, Kolpin 4 gal Gas Pack, 3" Passenger Foot Risers, 3-Headlight Mod, K&N Filter

SOLD 2010 Sportsman 300: Polaris 2500 lb. Winch, Kolpin Rear Seat (for the dog), UNI Foam Filter
SOLD 2006 Sportsman 700 Twin EFI: 27" Mud-Lite XTR, Superwinch Terra 35 w/Synthetic Rope, Polaris HD Front Springs, OEM Front Bumper Guard, WES Rear Seat, Kimpex Fender Guards w/Footpegs, 3-Headlight Mod, K&N Filter, Symtec Heated Grips

Last edited by AKStew; 04-30-2012 at 11:27 PM.
AKStew is offline  
post #5 of 5 (permalink) Old 05-01-2012, 07:10 AM Thread Starter
Junior Member
 
rghanlin's Avatar
 
Join Date: Apr 2012
Location: Ohio USA
Posts: 6
Checked the fuel switch and the run switch first,because I've done both myself. The brake has to be pulled for it to fire,the brake light comes on which makes me think the wires are OK but I couldn't get it open to check inside , going to try again today,I'll let you know how that goes. Thanks.
rghanlin is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
4x4 does not turn off by switch and tires wont turn but axle do Jzander27 ATV Repair and Maintenance 2 10-25-2011 10:04 PM
Front right brake caliper clicks-no parking brake Gear_Head ATV Repair and Maintenance 0 09-23-2011 03:47 PM
2009 Sportsman 550XP one rear brake? Downtown ATV Brakes & Suspension 2 05-17-2011 02:23 PM
300 2x4 won't turn over Pakman ATV Repair and Maintenance 0 05-29-2009 08:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome