07 800 sportsman AWD & Check Engine Light - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-11-2010, 09:21 AM Thread Starter
Junior Member
 
Unistoner's Avatar
 
Join Date: Apr 2010
Posts: 5
Question 07 800 sportsman AWD & Check Engine Light

Hi, I'm having a little issue with my quad and I'm wondering if someone can help me out.

I bought the quad 2nd hand, only had 9hrs & 124km on it. It runs good, did some mud and trails and it ran great. I noticed when I was out on the sand dunes (around 16hrs total on the quad) I have a check engine light coming on.

Pretty much I've figured out that the check engine light only comes on while I have AWD engaged and only in Low or High Gear when at 3500-4000 and above rpms. Once the light comes on it stays on until RPMs are below 1200. Also I have verifed that all 4 of my wheels turn when AWD is on and the check engine light is on (muskegg is great for that eh).

Also I have only a single code that keeps coming back which is code 25 for Invalid Trans gear.

I've check over majority of wiring and connectors and everything seems fine. I'm just trying to check everything I can myself before taking it to a dealer since I'm I'm a little tight on cash at the moment. So any advice would be appreciated.

Thanks alot.
Unistoner is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-11-2010, 06:02 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Welcome aboard!




I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
post #3 of 5 (permalink) Old 04-13-2010, 05:11 PM Thread Starter
Junior Member
 
Unistoner's Avatar
 
Join Date: Apr 2010
Posts: 5
Ty for the welcome Bruce.
Unistoner is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 04-25-2010, 06:35 PM Thread Starter
Junior Member
 
Unistoner's Avatar
 
Join Date: Apr 2010
Posts: 5
Anyways for anyone who was curious it turned out to be a faulty trans pos selector switch.
Unistoner is offline  
post #5 of 5 (permalink) Old 04-25-2010, 08:13 PM
Polaris ATV Legend
 
blueline15's Avatar
 
Join Date: Feb 2009
Location: Washington State
Posts: 6,903
wow! never would have guess it. thanks for following up with what was wrong. im sure it will help someone else in the future



blueline15 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Tags
800 efi, awd, check engine

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2017 Sportsman 850SP phantom check engine light? SquireSCA Polaris Sportsman 10 02-09-2019 12:53 PM
Check Engine Light 2016 570 Beretta Polaris Sportsman 570 5 12-31-2018 06:13 PM
Sportsman 600 Primary Help Needed TooSlo ATV Repair and Maintenance 8 07-23-2018 11:58 AM
Check Engine Light on but cannot access DIAGCODE Stryker818 ATV General Discussion 9 11-16-2017 02:38 PM
EPS light Check engine light and rough idle NJRider57 ATV Repair and Maintenance 2 03-14-2017 11:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome