Polaris sportsman 500x2 map sensor problem - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 06-08-2013, 04:24 PM Thread Starter
Junior Member
 
PolarisUK's Avatar
 
Join Date: Jun 2013
Location: England
Posts: 2
Polaris sportsman 500x2 map sensor problem

Hello there i am very new to this, not to sure if i posted in correct thread. I have a 2009 polaris sportsman 500 x2, i noticed it started to loose power when high revs so i took it to my local polaris dealer and it come back as the map sensor, he then noticed the wires had come out of the connection , anyways he put new prongs on the end of wires and fitted it back in and everything was fine. I then noticed it was doing it again so it musnt of holded up even though he put some silicon around it. He told me that if it happend again i would have to get a complete wiring loom for quad as the map sensor is part of wiring loom, and then he droped the bombshell and said it would be a pricey job. Just wanted to know if he is trying to have my pants down with the wiring loom or is he telling me the truth. Many thanks

Dan
PolarisUK is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-09-2013, 12:46 AM Thread Starter
Junior Member
 
PolarisUK's Avatar
 
Join Date: Jun 2013
Location: England
Posts: 2
If anybody has any information regarding this Matter i would be more than grateful for any help. Thankyou
PolarisUK is offline  
post #3 of 3 (permalink) Old 06-09-2013, 05:02 AM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Welcome to the board!



Bruce! is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
looks like I have T map sensor problem ATVBud Polaris XP 23 10-09-2017 11:16 AM
2006 polaris sportsman 500x2 owner's manual wizard0680 ATV Parts for Sale 5 11-28-2012 05:58 PM
??? 09 500x2 problem scott09 Polaris Sportsman 3 06-11-2012 02:58 PM
2006 Sportsman 500 HO fan/HEAT sensor problem cn44 ATV Repair and Maintenance 3 12-28-2011 06:19 PM
MAP sensor problem Manny ATV Repair and Maintenance 0 06-21-2011 07:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome