2012 Sportsman 800 EFI Speddometer Display - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-30-2014, 04:49 PM Thread Starter
Junior Member
 
shortstack2112's Avatar
 
Join Date: Jan 2014
Posts: 4
2012 Sportsman 800 EFI Speddometer Display

Hey guys, my buddy has a 2012 Sportsman 800 EFI and I'm not sure how he did it but he ended up wacking his speedo and cracking the display on it.

That's the only thing that's damaged, nothing on the board looks cracked or unsoldered.

My question is, does anyone know if I can get the display separate from the rest of the speedo? The display is clearly proprietary as it has specific icons for what appears to be suspension or engine warnings.

I'd really like to spare him the need to buy a whole new speedo.
shortstack2112 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-30-2014, 04:54 PM
Polaris ATV Legend
 
al53's Avatar
 
Join Date: Nov 2013
Location: Massachusetts
Posts: 1,891
does the display still work....if so just get a piece of clear vinyl laminate plastic and cover cracked area..keep it water proof....go to a shop that does vinyl signs on cars and ask for a cut off piece
al53 is offline  
post #3 of 8 (permalink) Old 01-30-2014, 04:56 PM Thread Starter
Junior Member
 
shortstack2112's Avatar
 
Join Date: Jan 2014
Posts: 4
I would imagine it doesn't.

I should have mentioned that I can see the liquid crystal leaking out I apologize for not including that information. Thanks!
shortstack2112 is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 01-30-2014, 05:09 PM
Polaris ATV Legend
 
al53's Avatar
 
Join Date: Nov 2013
Location: Massachusetts
Posts: 1,891
ok..i see now..its leaking....its toast..lol....I bet thats a OUCH part to replace...
al53 is offline  
post #5 of 8 (permalink) Old 01-30-2014, 05:11 PM Thread Starter
Junior Member
 
shortstack2112's Avatar
 
Join Date: Jan 2014
Posts: 4
Yeah the speedo unit is pretty expensive but the display is the only part damaged. It costs next to nothing to make those LCDs, I was hoping somebody would have a bright idea about where I could find one.
shortstack2112 is offline  
post #6 of 8 (permalink) Old 01-30-2014, 05:15 PM
Polaris ATV Legend
 
al53's Avatar
 
Join Date: Nov 2013
Location: Massachusetts
Posts: 1,891
al53 is offline  
post #7 of 8 (permalink) Old 01-30-2014, 05:20 PM Thread Starter
Junior Member
 
shortstack2112's Avatar
 
Join Date: Jan 2014
Posts: 4
Thanks for the link. I'm not sure that's right. I'll have him look at it. Thank you.
shortstack2112 is offline  
post #8 of 8 (permalink) Old 01-31-2014, 06:14 AM
Moderator
 
polman500's Avatar
 
Join Date: Nov 2009
Location: SE Kentucky
Posts: 7,999
That link is for a 850...won't work.
Looks like around $300 at cheapcycleparts.com
On the bright side, he gets to start all over again with 0 hrs. and 0 miles!

Last edited by polman500; 01-31-2014 at 06:17 AM.
polman500 is online now  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Tags
2012, 800 efi, display, speedometer

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 550 EPS display problems? 1ninjanina Polaris XP 0 06-15-2013 03:48 PM
06 500 EFI Sportsman RPM display. Nikolas Polaris Sportsman 0 09-20-2012 11:26 AM
450 sportsman time display meho156 Polaris Sportsman 2 09-13-2011 04:17 PM
07 sportsman 500 efi no display or anything wingnutt ATV Repair and Maintenance 3 04-05-2011 09:52 AM
07, 450 Sportsman. No power to display. Ennis37 ATV Repair and Maintenance 1 11-30-2010 11:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome