sportsman 400 cooling system - Polaris ATV Forum
ATV Repair and Maintenance Having problems? Doing a rebuild? All Repair/Maintenance Discussions here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-30-2016, 12:30 PM Thread Starter
Junior Member
 
spudneck's Avatar
 
Join Date: Jun 2016
Location: north idaho
Posts: 2
Unhappy sportsman 400 cooling system

hello all, new to the forum. old news.. new thread. i couldn't find any recent discussion about this, sorry if i'm in the wrong area. second owner 2010 sportsman 400 ho 200mi. first few short rides never heard the fan come on. hot engine light works when key first turned on, after finding the wire to sensor on engine block unplugged. got braver today, temps. in the high 70s, rode 2.5 miles road and trail. still no fan but no hot engine light. smelled hot after shutting it down. full rad and engine hot to touch. help afraid to ride it! thanks for any suggestions


Update

perserverance pays off. i took some info from older threads on overheating issues and did this. i verified the fan actually worked by unplugging it from the fan switch on the radiator and jumping it with the the key on, it ran. i drove the rig alittle to warm it up, parked it front wheels uphill, removed rad cap and let it idle. with a couple revs i saw a big burp. yeah. meanwhile i hooked ohm meter to fan switch which read open (no fan). i stole the wifes meat thermometer and placed into the rad and began revving the engine. watching the temp. go up over 170, i noticed the ohm meter had a closed reading (fan on). so i plugged in the fan and it started right up. definitely had some air in the system. time to ride!!!!!

Last edited by spudneck; 06-30-2016 at 03:46 PM. Reason: update
spudneck is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Repair and Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Softer rear shocks/springs? Unitoo1 Polaris Sportsman 11 01-04-2018 04:43 AM
sportsman 400 cooling system spudneck Polaris Sportsman 0 06-30-2016 12:01 PM
Hub strut compatability sniper4x4 ATV Brakes & Suspension 3 04-05-2016 07:24 AM
1996 sportsman 400 2mcgoo ATV Repair and Maintenance 7 01-28-2016 12:06 PM
compatability Dawgs Polaris Sportsman 1 12-07-2015 02:41 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome