06 Sportsman 450 wont idle, back fires and bogs in mud - Polaris ATV Forum
ATV Visual & Body Modifications Post any visual modifications you have done to your ATV vehicle here.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-14-2019, 05:21 PM Thread Starter
Junior Member
 
GameGlitch's Avatar
 
Join Date: May 2019
Posts: 2
06 Sportsman 450 wont idle, back fires and bogs in mud

wrong thread

Last edited by GameGlitch; 05-14-2019 at 05:23 PM. Reason: wrong thread
GameGlitch is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris ATV Technical Discussions > ATV Visual & Body Modifications

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 Polaris sportsman 500 bogging and back firing when letting off throttle Theking858 ATV Repair and Maintenance 0 12-30-2018 08:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome