Polaris ATV Forum - View Profile: Karcillo12

Karcillo12 Karcillo12 is offline

Junior Member

  Feedback Score

iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback
  Past
Month
Past
6 Months
Past
12 Months
Positive Positive 0 0 0
Neutral Neutral 0 0 0
Negative Negative 0 0 0

  Statistics

Total Posts
General Information
  • Last Activity: 09-17-2019 08:41 AM
  • Join Date: 09-13-2019
  • Referrals: 0

  Mentions

No results to display...

  Quotes

09-17-2019
06:34 AM - Karcillo12 quoted latebird in post 2010 Polaris 500 H.O wont accelerate
When the overheat light came ...
09-16-2019
07:51 AM - Karcillo12 quoted latebird in post 2010 Polaris 500 H.O wont accelerate
One is the vent hose from the...
09-15-2019
10:28 AM - Karcillo12 quoted latebird in post 2010 Polaris 500 H.O wont accelerate
Check the intake duct for an ...
09-14-2019
03:38 PM - Karcillo12 quoted latebird in post 2010 Polaris 500 H.O wont accelerate
It's rubber - squeeze it, twi...
03:36 PM - Karcillo12 quoted jwaugh in post Deleted Posts
03:35 PM - Karcillo12 quoted jwaugh in post 2011 Sportsman 500 ho cutting in and out
I had the same problem on a...
11:01 AM - Karcillo12 quoted latebird in post 2010 Polaris 500 H.O wont accelerate
Based on the pic, the enriche...
09:43 AM - Karcillo12 quoted polman500  in post 2010 Polaris 500 H.O wont accelerate
Clean the carb - it runs fine ...
09:43 AM - Karcillo12 quoted latebird in post 2010 Polaris 500 H.O wont accelerate
Clean the carb - it runs fine...
08:51 AM - polman500  quoted Karcillo12 in post 2010 Polaris 500 H.O wont accelerate
Clean the carb - it runs fine w...
08:33 AM - Karcillo12 quoted latebird in post 2010 Polaris 500 H.O wont accelerate
Clean the carb - it runs fine...
09-13-2019
06:30 PM - Karcillo12 quoted Theking858 in post 2011 Sportsman 500 ho cutting in and out
I took the cdi voltage regulato...
05:39 PM - Karcillo12 quoted bp405  Premium Member in post 2010 Polaris 500 H.O wont accelerate
Ok so that sounds like a c...
05:15 PM - Karcillo12 quoted bp405  Premium Member in post 2010 Polaris 500 H.O wont accelerate
Sounds like the belt is sl...
 
For the best viewing experience please update your browser to Google Chrome