2004 magnum 330 - Polaris ATV Forum
Polaris Magnum Discussions for the Polaris Magnum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-16-2019, 09:17 AM Thread Starter
Junior Member
 
rsyates's Avatar
 
Join Date: Sep 2019
Posts: 2
2004 magnum 330

My speed meter got broke. Now I have no fire I heard if speed meter ain't plugged in it won't fire. Is this true n can I splice wires to make it fire
rsyates is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-16-2019, 11:40 AM
Polaris ATV Legend
 
latebird's Avatar
 
Join Date: May 2014
Location: Illinois
Posts: 4,571
If the speedo is broke, all you have to do is disconnect the black wire on pin 4 of the 16 pin connector - NOTE: the black wire is the kill wire - it is used by the speed limiter function of the speedo to limit speed in reverse - with the wire disconnected, it will run as fast backwards as forwards, but to the best of my knowledge, just unplugging the speedo will not kill spark.

The ignition is AC excited (does not need a battery to run) - the black wire is a kill wire - it goes to the key switch, handlebar kill switch, throttle safety switch and speedo - disconnected at the CDI unit, it eliminates all methods to kill the engine

Shop Owner and Mechanic with over 50 years experience
latebird is online now  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Magnum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome