AWD light not on/ 4WD not working - Polaris ATV Forum
Polaris Magnum Discussions for the Polaris Magnum

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-07-2013, 07:07 AM Thread Starter
Junior Member
 
kwhite's Avatar
 
Join Date: Nov 2013
Posts: 6
AWD light not on/ 4WD not working

2000 Magnum 500, went to load it in the truck and the AWD light does not come on and the 4WD is not working. Any ideas ??
kwhite is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-07-2013, 07:50 AM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Welcome to the board!




I tried setting my password to "penis" but it said my password wasn't long enough...
Bruce! is offline  
post #3 of 8 (permalink) Old 11-11-2013, 12:39 PM
Junior Member
 
Snoxr107x's Avatar
 
Join Date: Jun 2010
Location: SE WI
Posts: 6
All electronics go through speedo.
I would start there
Snoxr107x is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 11-11-2013, 05:02 PM
Polaris ATV Legend
 
RVS Performance's Avatar
 
Join Date: Sep 2012
Location: North Branch, MN
Posts: 5,753
I know it's stupid, but is the light burnt out?
RVS Performance is offline  
post #5 of 8 (permalink) Old 11-13-2013, 05:37 AM Thread Starter
Junior Member
 
kwhite's Avatar
 
Join Date: Nov 2013
Posts: 6
Headlight ? No, Speedo backlight... Its not on, not sure if it has one to be honest. Im trying to fix this thing up so I can sell it, bought a Ranger :]
kwhite is offline  
post #6 of 8 (permalink) Old 11-13-2013, 05:54 AM
Junior Member
 
Snoxr107x's Avatar
 
Join Date: Jun 2010
Location: SE WI
Posts: 6
I had same issue with a 2001
Speedo started to not work, then AWD light stopped coming on and 4wd didn't engage
Had to replace speedo, try and find a used one, factory is very proud and charges a lot.
Test the speedo
Snoxr107x is offline  
post #7 of 8 (permalink) Old 11-13-2013, 06:02 AM Thread Starter
Junior Member
 
kwhite's Avatar
 
Join Date: Nov 2013
Posts: 6
How do you test it ??
kwhite is offline  
post #8 of 8 (permalink) Old 11-13-2013, 06:58 AM
Junior Member
 
Snoxr107x's Avatar
 
Join Date: Jun 2010
Location: SE WI
Posts: 6
I had neither the time nor the resources to do it myself.
Maybe someone else could help explain, sorry
Ill check my manual though and let you know if I find anything out
Snoxr107x is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Magnum

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
NEW REVERSE OVERRIDE & REVERSE LIGHT MOD!!! no switches and working scroll feature! QuickSilver74 Polaris ATV How-Tos 103 12-08-2016 03:53 PM
NEW REVERSE OVERRIDE & REVERSE LIGHT MOD!!! no switches and working scroll feature! QuickSilver74 Polaris Sportsman 190 05-31-2016 06:50 PM
2004 sportsman 400 battery warning light flashing and fan not working ford4x4dad Polaris Sportsman 2 06-20-2014 10:23 AM
speedo back light not working stanley Polaris Sportsman 0 01-14-2011 03:41 PM
Neutral Light Not Working nastypredatorBV ATV New Members 0 09-11-2009 10:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome