Polaris outlaw 110 stalls in when wet? - Polaris ATV Forum
Polaris Outlaw Discussions for the Polaris Outlaw 50,90,450, 525

 1Likes
  • 1 Post By Doc8404
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-14-2017, 08:29 PM Thread Starter
Junior Member
 
Ptiso27's Avatar
 
Join Date: Nov 2017
Posts: 2
Polaris outlaw 110 stalls in when wet?

I'm new to the forum. I bought my 2 kids 110 efi's last year. 1 outlaw & 1 sportsman. They run great. The kids love them. One problem is if it is wet out and they rip through a puddle, I'm not talking about a deep puddle. We're talking 3 to 6 inches deep. But at speed so as to splash water up. They will stall and be no start for 5 or so minutes. Seems electrical but other than the one module up near the front I don't know of anything. Plus I sprayed that box with it running and it does not stall. I sprayed all up under everything and could not get either of them to stall. But one whoosh through a puddle and shutdown!!

I would think there is a common denominator because both machines do it. Of course the outlaw more than the sportsman just due to the lack of protection from water splash on the outlaw. Any magic bullets for this??

Thanks for any help

Family set up= 110 sportsman, 110 outlaw, 570 sportsman EPS, Arctic Cat 550H1 2up.
Ptiso27 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-07-2018, 05:59 PM
Junior Member
 
Jjjquadlife's Avatar
 
Join Date: Jan 2018
Location: CALIFORNIA
Posts: 11
Did you ever figure this out? I have an outlaw 110 that don't idle and no power. Just wondering if u got it fixed.
Jjjquadlife is offline  
post #3 of 6 (permalink) Old 01-09-2018, 10:27 AM
Junior Member
 
Caidly's Avatar
 
Join Date: Jan 2018
Location: Northern NJ
Posts: 3
Spray underside with Liquid Film

https://www.google.com/search?q=liquid+film&ie
Caidly is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 01-10-2018, 05:45 AM
Premium Member
 
fitsector's Avatar
 
Join Date: Apr 2016
Location: MEXICO
Posts: 404
Check all your fuses are properly in place and tight. I had a same problem with my Phoenix 200 and was a loose fuse. Water was getting inside the fuse slot.

Life is to short to live it miserably
fitsector is offline  
post #5 of 6 (permalink) Old 01-10-2018, 08:33 AM
Extreme ATV Enthusiast
 
Doc8404's Avatar
 
Join Date: Dec 2017
Location: Oneida County, central NY
Posts: 339
Garage
ensure you go through every connection with dielectric grease also.
Caidly likes this.

2018 Sportsman Touring 850 SP
Delivery 12/22/2017.
Polaris 3500 winch.
Cabela's Deluxe ATV Cover, size XXL.
Polaris handguards and mount.
Guru CTR1 with middle mesh and CF3. Ordered 12/22/17. Rec’d 1/26. Installed 2/4 without lower bolts.
IB HDPE skids. Shipped 1/9. Rec'd 1/11. Installed 1/14.
Doc8404 is offline  
post #6 of 6 (permalink) Old 01-10-2018, 09:26 AM
Polaris ATV Legend
 
latebird's Avatar
 
Join Date: May 2014
Location: Illinois
Posts: 4,363
Quote:
Originally Posted by Doc8404 View Post
ensure you go through every connection with dielectric grease also.
In the 70's we filled all the connectors with Vaseline - dielectric grease was either not available or too expensive back then. Did the same thing - kept water out of the connectors. I'm gonna get flack for this, but when water gets into a connector (specifically a loose connector) the insulating properties of the water cause a loss of continuity. When the connector dries out the connection remakes and it is fine till it gets wet again.

Let me explain - water is an insulator - it is made of hydrogen and oxygen - neither hydrogen or oxygen conduct electricity, but water will carry many conductive materials - nickel, iron, sodium, copper to name a few - but water in a connector can cause a loss of continuity.
latebird is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Outlaw

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
20 inch tires Polaris outlaw 110 bigred78 Polaris Outlaw 10 03-05-2019 09:31 PM
2018 Polaris Outlaw 110 vs. Honda TRX90X VS_Goose Polaris ATV News 4 01-08-2018 08:25 AM
2018 Polaris Outlaw 110 speed limiter missing chucklaw ATV General Discussion 5 01-06-2018 02:04 PM
polaris 570 2015 exhaut heating gab570 Polaris Sportsman 2 05-19-2017 10:58 AM
Welcome to the new Polaris ATV Forum! dascrow Polaris ATV News 2 09-20-2010 01:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome