2016 Polaris outlaw 110 no power dies at idle - Page 3 - Polaris ATV Forum
Polaris Outlaw Discussions for the Polaris Outlaw 50,90,450, 525

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 35 (permalink) Old 08-26-2019, 05:29 PM
Junior Member
 
kodiak1252's Avatar
 
Join Date: Aug 2019
Posts: 1
i have same thing going on with a 2016 Polaris Sportsman 110. All started after my daughter ran it out of fuel. Did you find the problem?
kodiak1252 is offline  
Sponsored Links
Advertisement
 
post #22 of 35 (permalink) Old 09-13-2019, 05:43 PM
Junior Member
 
Octane742's Avatar
 
Join Date: Sep 2019
Posts: 8
Same problem.. have you found something?
Octane742 is offline  
post #23 of 35 (permalink) Old 09-14-2019, 08:53 AM
Polaris ATV Legend
 
latebird's Avatar
 
Join Date: May 2014
Location: Illinois
Posts: 4,545
Has anyone found a definite cause of the problem? I have worked on many Chinese EFI models and they all suck! There are no service manuals and specs are sketchy at best. One I worked on at the bequest of the distributor in California: the vehicle ran fine, but would stall each time stopped or would stall when the engine was revved and then the throttle was simply closed.

Replaced the fuel pump first, injector second, throttle body third, fourth was the ECU, fifth was the battery - the solution turned out to be a valve adjustment - the distributor was making suggestions and working with the manufacturer and supplying parts, but there was no written procedure and no electronic diagnostics available outside of the factory in China where it was produced. Perhaps Polaris has some information and procedures that is not supplied by the Chinese for their Chinese manufactured products.

Shop Owner and Mechanic with over 50 years experience
latebird is online now  
Sponsored Links
Advertisement
 
post #24 of 35 (permalink) Old 09-16-2019, 05:00 AM
Junior Member
 
Octane742's Avatar
 
Join Date: Sep 2019
Posts: 8
Found the problem... battery voltage To low.. i charge the battery with a battery tender all week end, try this morning and no more problem. I also check the charging system ..work fine 14.2v try that and let me know !
Octane742 is offline  
post #25 of 35 (permalink) Old 09-16-2019, 06:12 AM
Junior Member
 
Octane742's Avatar
 
Join Date: Sep 2019
Posts: 8
Ran Good for 20 minutes and than small again. 😥
Octane742 is offline  
post #26 of 35 (permalink) Old 09-16-2019, 07:31 AM
Polaris ATV Legend
 
latebird's Avatar
 
Join Date: May 2014
Location: Illinois
Posts: 4,545
Try a new battery and remember the charging system does not charge below about 2500 RPM - at low speeds and at idle the battery is operating at a loss - it takes 20 minutes of riding at engine speed over 2500 RPM to replace the energy used starting the engine

Shop Owner and Mechanic with over 50 years experience
latebird is online now  
post #27 of 35 (permalink) Old 09-16-2019, 09:38 AM
Junior Member
 
Octane742's Avatar
 
Join Date: Sep 2019
Posts: 8
I have try another battery. Same thing, booster pack,same thing. Now it run 10 sec and die.fuel pump is new
Octane742 is offline  
post #28 of 35 (permalink) Old 09-16-2019, 09:41 AM
Junior Member
 
Octane742's Avatar
 
Join Date: Sep 2019
Posts: 8
When he dies, he never restart until i shut the key off and on..theres no spark until i reset the switch off and on
Octane742 is offline  
post #29 of 35 (permalink) Old 09-16-2019, 10:52 AM
Polaris ATV Legend
 
latebird's Avatar
 
Join Date: May 2014
Location: Illinois
Posts: 4,545
I think I would quit flogging it and take it to a dealer - maybe the valves just need to be adjusted - just another wild guess?

It's not that hard to eliminate the fuel injection and install a carb.

Shop Owner and Mechanic with over 50 years experience
latebird is online now  
post #30 of 35 (permalink) Old 09-16-2019, 11:33 AM
Junior Member
 
Octane742's Avatar
 
Join Date: Sep 2019
Posts: 8
Valve adjustment have nothing To do with the spark..
Octane742 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Outlaw

Tags
outlaw 110 polaris fuel

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Polaris outlaw 110 stalls in when wet? Ptiso27 Polaris Outlaw 5 01-10-2018 09:26 AM
2018 Polaris Outlaw 110 vs. Honda TRX90X VS_Goose Polaris ATV News 4 01-08-2018 08:25 AM
2018 Polaris Outlaw 110 speed limiter missing chucklaw ATV General Discussion 5 01-06-2018 02:04 PM
Polaris sportsman 500 efi dies when idle and backfire AND ATV New Members 7 10-31-2017 07:09 PM
May 2016 - Polaris ATV of the Month Voting! Wreckless ATV of the Month 1 05-16-2016 07:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome