couple questions - Polaris ATV Forum
Polaris Predator All discussions for the Polaris Predator

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 03-04-2011, 07:25 PM Thread Starter
ATV Enthusiast
 
04Predator4408's Avatar
 
Join Date: Oct 2010
Location: PA
Posts: 37
Thumbs up couple questions

im looking at rebuilding my top end on my 04 predator 500... I was wondering if you guys could help with a good quality piston and cams im going with the kibble white valves im pretty sure... would i need to buy new lifters with those?

also for the kibble white valves and springs anyone have an idea of what size shims i would need when i rebuild?

i want good quality and reliabe without spending a ton of cash

ive heard wiseco pistons are cheap for a reason so i was going to stay away from them.

any help would be appreciated thanks guys
04Predator4408 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 03-04-2011, 09:45 PM
Junior Member
 
05TroyLee's Avatar
 
Join Date: Feb 2011
Location: Tucson, Arizona
Posts: 10
Send a message via AIM to 05TroyLee Send a message via Yahoo to 05TroyLee
I have used Wiesco Pistons in a couple different rebuilds and never had a problem but usually sell things often so only ran them about a year +/- after rebuild. I found a set of Moose Valves with the springs and all hardware for $120 through ridenow and if you run them with Hot Rods cams it should be a pretty good build, as far as the shims you will have to put it together to determine that, if you dont go bigger valves it may be close to stock shim size

Hope that helps
05TroyLee is offline  
post #3 of 9 (permalink) Old 03-04-2011, 11:56 PM
ATV Enthusiast
 
Predasaurs's Avatar
 
Join Date: Dec 2010
Location: canada
Posts: 80
wiseco and j.e good brands , im running kibble white springs , hot cams , and new valves , good setup so far
Predasaurs is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 03-05-2011, 03:18 AM Thread Starter
ATV Enthusiast
 
04Predator4408's Avatar
 
Join Date: Oct 2010
Location: PA
Posts: 37
How much did that set up run you if you don't mind me asking? Also I have heard to try to use forged piston instead of cast wiseco are cast if I'm not mistaken right?

Has any one heard anything about namura pistons or whatever??
04Predator4408 is offline  
post #5 of 9 (permalink) Old 03-05-2011, 03:44 AM Thread Starter
ATV Enthusiast
 
04Predator4408's Avatar
 
Join Date: Oct 2010
Location: PA
Posts: 37
Quote:
Originally Posted by Predasaurs View Post
wiseco and j.e good brands , im running kibble white springs , hot cams , and new valves , good setup so far
what piston are you running?
04Predator4408 is offline  
post #6 of 9 (permalink) Old 03-05-2011, 08:12 AM
ATV Enthusiast
 
Predasaurs's Avatar
 
Join Date: Dec 2010
Location: canada
Posts: 80
Quote:
Originally Posted by 04Predator4408 View Post
Quote:
Originally Posted by Predasaurs View Post
wiseco and j.e good brands , im running kibble white springs , hot cams , and new valves , good setup so far
what piston are you running?
j.e big bore kit 560cc
Predasaurs is offline  
post #7 of 9 (permalink) Old 03-05-2011, 12:02 PM
Junior Member
 
05TroyLee's Avatar
 
Join Date: Feb 2011
Location: Tucson, Arizona
Posts: 10
Send a message via AIM to 05TroyLee Send a message via Yahoo to 05TroyLee
I have never used a Namura piston but I have never had a problem with thier gaskets so if the quality is the same I would assume they are not terrible..

Has anyone heard of the JE 600cc Kit? I cant seem to find anything about it online and wanting to put it in my 05 Predator
05TroyLee is offline  
post #8 of 9 (permalink) Old 03-05-2011, 12:26 PM
ATV Enthusiast
 
Predasaurs's Avatar
 
Join Date: Dec 2010
Location: canada
Posts: 80
Quote:
Originally Posted by 05TroyLee View Post
I have never used a Namura piston but I have never had a problem with thier gaskets so if the quality is the same I would assume they are not terrible..

Has anyone heard of the JE 600cc Kit? I cant seem to find anything about it online and wanting to put it in my 05 Predator
i looked on their website and biggest was the 560


hpd also has great stuff
Predasaurs is offline  
post #9 of 9 (permalink) Old 03-05-2011, 03:02 PM Thread Starter
ATV Enthusiast
 
04Predator4408's Avatar
 
Join Date: Oct 2010
Location: PA
Posts: 37
I don't want to big bore it because of the cost and I also drops the reliability of the bike... has anyone had any problems with the big bores? I don't know much about them but if its worth the money maybe ill look into it
04Predator4408 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Predator

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie with a couple of questions. MadMedic ATV New Members 25 01-26-2011 02:03 PM
New Polaris owner with a couple of questions... Mike213 ATV General Discussion 9 01-15-2011 08:39 AM
New 850 owner, got a couple questions RED850XP Polaris XP 6 11-15-2010 09:58 PM
Looking at buying a quad and have a couple questions. wreckmaster Polaris Sportsman 2 08-19-2010 03:34 PM
2006 500HO - couple questions goatman-68 Polaris Sportsman 3 06-28-2010 05:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome