Predator out of Comission - Polaris ATV Forum
Polaris Predator All discussions for the Polaris Predator

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-09-2012, 07:12 PM Thread Starter
Junior Member
 
Hillbillydrummer's Avatar
 
Join Date: Nov 2011
Location: Hamptonville, NC
Posts: 25
Predator out of Comission

So I was riding my 05 pred yesterday, having a blast just flying and all of the sudden I lost all power and as soon as I pull the clutch in it cut off. I was not able to get it started back up. When I hit the start button the motor turns over but I have almost no compression. Im going to tear it down tomorrow to see whats up but wanted to get some insight from anyone who may know what problem could be. Im thinking my piston rings may be fried or something. Im just not sure because it was running fine a few days ago. Any ideas appreciated! Thanks! I will provide a link with a video of it trying to turn over if the sound of it will help anyone.

Here is the video.

http://www.youtube.com/watch?v=54EYo...ature=youtu.be

Last edited by Hillbillydrummer; 02-09-2012 at 08:44 PM.
Hillbillydrummer is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-09-2012, 08:07 PM
Extreme ATV Enthusiast
 
starpuss's Avatar
 
Join Date: Jun 2011
Location: Winnipeg Manitoba Canada
Posts: 239
Stuck Valve , Broken time Chain

2011 Polaris Sportsman 500 HO TRG
1997 polaris xplorer 400
1977 yamaha it175
1988 QuadZilla (Lt500R)
1985 Bigwheel (BW200)
starpuss is offline  
post #3 of 5 (permalink) Old 02-10-2012, 06:08 AM Thread Starter
Junior Member
 
Hillbillydrummer's Avatar
 
Join Date: Nov 2011
Location: Hamptonville, NC
Posts: 25
Ok. So here is an update. I tore it down to the cams. Timing chain is not broke but I removed the plug and apparently the piston hit my plug and trashed it. Thats the only thing I can think happened. I included a picture of the plug. Did it jump time? What would cause this to happen? Also, will I need to replace the piston? Any help appreciated! Thanks!
Attached Thumbnails
Click image for larger version

Name:	IMAG0051.jpg
Views:	194
Size:	92.2 KB
ID:	5805  
Hillbillydrummer is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 02-11-2012, 03:55 AM
Extreme ATV Enthusiast
 
joshr08's Avatar
 
Join Date: Mar 2011
Location: Carsonville
Posts: 401
sorry but loks to me like to busted a valve and the broken piece came up and into your plug. Get that head pulled off. Its not going to be pretty tho. There is no way for the piston to hit the plug its a busted valve.

04 Polaris predator 558 Flat track quad
04 Polaris predator 500 trail build(in the works)
started life as a replacement frame so a ground up build
Build predator and outlaw lowering kits
joshr08 is offline  
post #5 of 5 (permalink) Old 02-11-2012, 06:20 AM
Extreme ATV Enthusiast
 
starpuss's Avatar
 
Join Date: Jun 2011
Location: Winnipeg Manitoba Canada
Posts: 239
Dam.. Thats sucks man. Stuck Valve / then pistion hit the Valve witch got your plug.

Or you Broke your Rod. But then you should hear that when it spins over.

2011 Polaris Sportsman 500 HO TRG
1997 polaris xplorer 400
1977 yamaha it175
1988 QuadZilla (Lt500R)
1985 Bigwheel (BW200)
starpuss is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Predator

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome