Electrical problem please help!! - Polaris ATV Forum
Polaris Predator All discussions for the Polaris Predator

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-18-2012, 03:33 PM Thread Starter
Junior Member
 
Connor's Avatar
 
Join Date: Feb 2012
Location: Port perry on.
Posts: 2
Question Electrical problem please help!!

I have an 03 predator 500, I have been having some problems with it. I took it out for a ride it rode fine then died, back fired, then came back and it did this a few times. Now it will start but when I turn the head lights on it will die and then it there will be no power for a little while. I went through all the wiring cleaned and put electrical grease on all the connections, cleaned and tighten all the grounds. I'm lost, if any one can help that would be great!
Connor is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-18-2012, 03:50 PM
Polaris ATV Junkie!
 
SMP63's Avatar
 
Join Date: Mar 2011
Location: Zephyrhills,Fl.
Posts: 1,420
Welcome to the forum!!! Sounds like it could be the battery on its way out!!!

2011 Sportsman 500 H.O. Green
14" STI Wheels-26" Mud Trax X/L's
2500# polaris winch
Ricochet a-arm guards
Rev. override kit
Hid 3 light kit
3 light mod. w/relay

Uni air filter on both

Wifes
2011 Sportsman 500 H.O. Red
Ricochet a-arm guards
Hid 3 light kit
3 light mod. w/relay
Winch,wheels & tires still to go!
SMP63 is offline  
post #3 of 4 (permalink) Old 02-18-2012, 03:53 PM Thread Starter
Junior Member
 
Connor's Avatar
 
Join Date: Feb 2012
Location: Port perry on.
Posts: 2
Thanks, I just put a new batt in it 2 weeks ago.
Connor is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 02-18-2012, 06:05 PM
Polaris ATV Junkie!
 
SMP63's Avatar
 
Join Date: Mar 2011
Location: Zephyrhills,Fl.
Posts: 1,420
Put a meter on the battery & see what its got & then check it while its running. Could be the stator has quit working & the wheeler is running off the battery. Could also be the voltage regulator.

2011 Sportsman 500 H.O. Green
14" STI Wheels-26" Mud Trax X/L's
2500# polaris winch
Ricochet a-arm guards
Rev. override kit
Hid 3 light kit
3 light mod. w/relay

Uni air filter on both

Wifes
2011 Sportsman 500 H.O. Red
Ricochet a-arm guards
Hid 3 light kit
3 light mod. w/relay
Winch,wheels & tires still to go!

Last edited by SMP63; 02-18-2012 at 06:08 PM.
SMP63 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Predator

Tags
electrical, polaris, predator 500

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
electrical Problem? Hosstile ATV Repair and Maintenance 7 11-21-2011 10:14 AM
electrical problem rickv3 ATV New Members 3 02-13-2011 07:20 AM
electrical problem help please. moonman ATV Repair and Maintenance 3 02-09-2011 07:50 AM
Electrical Problem ldsims ATV Repair and Maintenance 3 04-26-2010 09:03 AM
Help! Electrical problem customnotch ATV Repair and Maintenance 0 11-26-2009 07:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome