Fuel Pump Humming - Louder & Longer - Polaris ATV Forum
Polaris Sportsman 570 Discussions for the all new 2014+ Polaris Sportsman 570

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 07-03-2017, 04:14 PM Thread Starter
Premium Member
 
BlueFire570SP's Avatar
 
Join Date: Jan 2016
Location: MO
Posts: 137
Garage
Question Fuel Pump Humming - Louder & Longer

So after a morning of riding I got back home and went to unload the 570 (nothing unusual during the ride happened). I am sure everyone is familiar with the sound you get when you click the key into the first position before starting, humming sound that lasts a few seconds and then stops, and it is my understanding that the sound is coming from the fuel pump. That is normal operation. This time the hum was much louder than normal, and after starting the 570 a minor hum was still heard over the idling engine. The hum continued until I shut the 570 off. I repeatd turning the 570 on and off a couple off times with the same result. Wondering what could be going on. Is my fuel pump going out?

2015 Sportsman 570 SP Touring
Polaris 2500 lb Winch
BlueFire570SP is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 07-03-2017, 05:34 PM
Premium Member
 
bp405's Avatar
 
Join Date: Sep 2011
Location: New York
Posts: 7,294
In my experience fuel pumps hum because they don't know the words .

Is it possible the amount of fuel in the tank is causing the difference in the sound you are hearing?

If that's not it changing noise levels of a component are an indicator that the component is going south.

2011 Sportsman® 800 EFI
GURU front brush guard
GURU rear brush guard
Polaris front lock n ride cargo box
Polaris rear rack extender
Warn RT 3.0 winch w/amsteel synthetic line
Viper aluminum haus fairlead
Polaris front spring adjusters
Ricochet a-arm guards
Ricochet full frame skid plate
ITP T-7 beadlock 14" w/OMF inner rim guards
Maxxis big horn 2.0 26x9 front
Maxxis big horn 2.0 26x11 rear
QSC clutch kit
EPI HD springs front n rear
ODI rogue 130mm grips
Ultraseal commercial grade tire sealant (front)
Highlifter tire sealant (rear)
CTEK 3300 battery maintainer
added 7 zerks
beefed up wiring harness
OGIO rear bag
ROTOPAX 1gal. + 2gal. gasoline can
Jccapri bushing kit
Kolpin Over Fenders
Rigid Industries E-Series 10" flood
Walker Evans struts
NGK Iridium's (2,500 miles on Champion's and they looked great!)
Odyssey Extreme battery PC545

2018 Sportsman® 570-T
2019 Aluma® A8818
2020 Outlander® 1000R XXC
bp405 is online now  
post #3 of 16 (permalink) Old 07-06-2017, 06:38 PM Thread Starter
Premium Member
 
BlueFire570SP's Avatar
 
Join Date: Jan 2016
Location: MO
Posts: 137
Garage
Quote:
Originally Posted by bp405 View Post
In my experience fuel pumps hum because they don't know the words .

Is it possible the amount of fuel in the tank is causing the difference in the sound you are hearing?

If that's not it changing noise levels of a component are an indicator that the component is going south.
Well I don't think is was the fuel tank level because I haven't changed it since the first post, but thanks for the suggestion. So three days in a row I have started the 570, and the issue no longer exists. The hum is back to normal and I can't hear anything once it is started and idling. Just one of those odd things I guess. I will just monitor it closely in the future to see if the issue comes back.

2015 Sportsman 570 SP Touring
Polaris 2500 lb Winch
BlueFire570SP is offline  
Sponsored Links
Advertisement
 
post #4 of 16 (permalink) Old 07-07-2017, 07:47 AM
Premium Member
 
bp405's Avatar
 
Join Date: Sep 2011
Location: New York
Posts: 7,294
Well hopefully it was just one of those "glitches in the matrix" and that was all. Best I can suggest since it's back to normal is keep an eye on it. Good luck. Update us if it does go south!

2011 Sportsman® 800 EFI
GURU front brush guard
GURU rear brush guard
Polaris front lock n ride cargo box
Polaris rear rack extender
Warn RT 3.0 winch w/amsteel synthetic line
Viper aluminum haus fairlead
Polaris front spring adjusters
Ricochet a-arm guards
Ricochet full frame skid plate
ITP T-7 beadlock 14" w/OMF inner rim guards
Maxxis big horn 2.0 26x9 front
Maxxis big horn 2.0 26x11 rear
QSC clutch kit
EPI HD springs front n rear
ODI rogue 130mm grips
Ultraseal commercial grade tire sealant (front)
Highlifter tire sealant (rear)
CTEK 3300 battery maintainer
added 7 zerks
beefed up wiring harness
OGIO rear bag
ROTOPAX 1gal. + 2gal. gasoline can
Jccapri bushing kit
Kolpin Over Fenders
Rigid Industries E-Series 10" flood
Walker Evans struts
NGK Iridium's (2,500 miles on Champion's and they looked great!)
Odyssey Extreme battery PC545

2018 Sportsman® 570-T
2019 Aluma® A8818
2020 Outlander® 1000R XXC
bp405 is online now  
post #5 of 16 (permalink) Old 07-09-2017, 06:12 AM
Extreme ATV Enthusiast
 
one7oh5's Avatar
 
Join Date: Jan 2015
Location: Ontario, Canada
Posts: 132
Garage
Mine does that about once or twice a year, totally random. So far it has caused no issues except for getting me worried.
I thought it could just be when it gets hot, but it doesn’t happen enough to make me think that’s the issue.
Hopefully she lasts forever, not something I want to replace.

2014 Sportsman 570 EFI
26" Kenda HTR Bearclaws on Delta Steels
RVS Clutch Kit
HD 12mm Tie Rods
En Route: SYATV Snorkel Kit, Custom Rad Relocate by Rubberdown Customs, HMF Titan Qs Blackout Exhaust, RVS Stage 3 ECU Tune, Highlifter High Clearance A-arms
one7oh5 is offline  
post #6 of 16 (permalink) Old 08-05-2017, 12:25 AM
Junior Member
 
mikelanglois's Avatar
 
Join Date: Aug 2017
Posts: 4
I have 2016 Polaris 570 as well..300 miles on it now...mine just started making the exact sound yours is making when I turn my key to the on position the pump gives me a loud whine sound...this issue happened 3 times over 2 days or riding..it seems to correct it self after so many hours of sitting but I was concerned my fuel pump was going or acting up...took it to polaris dealership on Thursday and although it was not making that sound anymore I did have a video of it that I showed the mechanic, he tested the pump and it shows working well but he definatley agreed it was the pump...it is still under warrenty so he is just putting a brand new pump in it today..something I don't want to pay for if off the warrenty as it was $865 before tax and shop rate!!! I have a video of it and I would like to send to you to see if it is the same issue as yours..
mikelanglois is offline  
post #7 of 16 (permalink) Old 08-05-2017, 03:52 PM
Junior Member
 
shanedoe's Avatar
 
Join Date: Sep 2015
Location: SWPA
Posts: 16
Mine made that random noise so for piece of mind I put an aftermarket from ebay on. If you know how to solder it is not that hard. Pump is less than $40, Hard part is getting all the plastics off to remove fuel tank.
shanedoe is offline  
post #8 of 16 (permalink) Old 08-06-2017, 05:57 AM
Polaris ATV Junkie!
 
cariboo's Avatar
 
Join Date: Jun 2012
Location: Bridge Lake BC
Posts: 1,056
if the trouble starts after trailering i am confident this is from the fuel swapping around without the fuel pump not running and this way you have air in your hoses

Last edited by cariboo; 08-07-2017 at 06:33 AM.
cariboo is offline  
post #9 of 16 (permalink) Old 08-06-2017, 06:44 PM Thread Starter
Premium Member
 
BlueFire570SP's Avatar
 
Join Date: Jan 2016
Location: MO
Posts: 137
Garage
Quote:
Originally Posted by mikelanglois View Post
I have 2016 Polaris 570 as well..300 miles on it now...mine just started making the exact sound yours is making when I turn my key to the on position the pump gives me a loud whine sound...this issue happened 3 times over 2 days or riding..it seems to correct it self after so many hours of sitting but I was concerned my fuel pump was going or acting up...took it to polaris dealership on Thursday and although it was not making that sound anymore I did have a video of it that I showed the mechanic, he tested the pump and it shows working well but he definatley agreed it was the pump...it is still under warrenty so he is just putting a brand new pump in it today..something I don't want to pay for if off the warrenty as it was $865 before tax and shop rate!!! I have a video of it and I would like to send to you to see if it is the same issue as yours..
Wow! That is really an expensive repair at the dealer. Mine has done it one more time since my original post, but it always corrects itself. I have my extended warranty still active as well, so it might be something I mention to the dealer sometime in the near future.

2015 Sportsman 570 SP Touring
Polaris 2500 lb Winch
BlueFire570SP is offline  
post #10 of 16 (permalink) Old 08-06-2017, 07:02 PM Thread Starter
Premium Member
 
BlueFire570SP's Avatar
 
Join Date: Jan 2016
Location: MO
Posts: 137
Garage
Quote:
Originally Posted by cariboo View Post
if the trouble starts after trailering i am confident this is from the fuel swapping around without the fuel pump running and this way you have air in your hoses
Interesting idea. I will pay close attention to that. The last time it happened the situation was the following. I hauled the 570 to the riding destination. I did some trail riding for roughly an hour, took a break for lunch, and on the next start it began making the noise again. It did it on the following start as well. When I started the 570 to trailer it, no noise. I hauled the 570 home after about 3.5 hours of total riding and a 45 minute trip home. When I started the 570 to unload it, no noise.

I was thinking heat related issue. Kind of confusing though, because no potential cause seems completely consistent.

2015 Sportsman 570 SP Touring
Polaris 2500 lb Winch
BlueFire570SP is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman 570

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fuel pump & Sportsman 500 EFI Carpetman22 ATV General Discussion 3 01-15-2018 11:48 PM
They call it a fuel pump scarpacci Polaris Magnum 9 08-22-2017 08:07 AM
Classic symptoms of Fuel Pump Failure Deucer Polaris XP 6 06-23-2017 05:53 PM
Fuel Pump Failure (Pics) XP_1K Polaris Scrambler XP 1000 4 03-30-2017 04:50 AM
700 efi , pressure regulator, fuel pump Firejake77 Polaris Sportsman 0 11-23-2016 11:17 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome