Ricochet Rear A-Arm plates - Polaris ATV Forum
Polaris Sportsman 570 Discussions for the all new 2014+ Polaris Sportsman 570

 1Likes
  • 1 Post By polman500
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-07-2019, 04:03 PM Thread Starter
ATV Enthusiast
 
rainmanx's Avatar
 
Join Date: Jun 2019
Location: Chicagoland
Posts: 38
Ricochet Rear A-Arm plates

I purchased 2 full sets of Ricochet Armor for our new machines. Everything except the rear is fine.

On the rears, it doesn't seem to line up with the instructions. If I work with it, I can make it work by placing clamps under the cv joint, and then it still seems wrong.

Is it possible they are different for 2019?

I would take a picture, but I just came in and wife says time to call it a day!

Thanks!
rainmanx is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-07-2019, 04:55 PM
Moderator
 
polman500's Avatar
 
Join Date: Nov 2009
Location: SE Kentucky
Posts: 8,087
570 base? SP? Touring? SP Touring?

Last edited by polman500; 07-07-2019 at 05:01 PM.
polman500 is online now  
post #3 of 6 (permalink) Old 07-07-2019, 05:11 PM
Moderator
 
polman500's Avatar
 
Join Date: Nov 2009
Location: SE Kentucky
Posts: 8,087
Here's an installation video. Seems pretty straight forward if you have the correct guards for your particular machine.

polman500 is online now  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 07-08-2019, 01:58 AM Thread Starter
ATV Enthusiast
 
rainmanx's Avatar
 
Join Date: Jun 2019
Location: Chicagoland
Posts: 38
Quote:
Originally Posted by polman500 View Post
Here's an installation video. Seems pretty straight forward if you have the correct guards for your particular machine.

https://www.youtube.com/watch?v=b-_0ZG5mD24
That is completely different than what I tried..I am going to try that tonight.

Thanks!
rainmanx is offline  
post #5 of 6 (permalink) Old 07-08-2019, 05:47 PM Thread Starter
ATV Enthusiast
 
rainmanx's Avatar
 
Join Date: Jun 2019
Location: Chicagoland
Posts: 38
Thank you very much for that video! I feel stupid! Because the diagram was reversed on the main plate (where the one bolt went), I figured the others were also a "mirror". I installed them on the wrong side, and then figured out a way to make it work!

Damn...Thanks everyone!
rainmanx is offline  
post #6 of 6 (permalink) Old 07-08-2019, 07:53 PM
Moderator
 
polman500's Avatar
 
Join Date: Nov 2009
Location: SE Kentucky
Posts: 8,087
LOL, don't beat yourself up too bad. Experience is the best teacher. I bet you could put a set on in just a few minutes now!
sportsmandan likes this.
polman500 is online now  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman 570

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome