Chirping noise over bumps - Polaris ATV Forum
Polaris Sportsman 570 Discussions for the all new 2014+ Polaris Sportsman 570

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-17-2019, 06:33 PM Thread Starter
ATV Enthusiast
 
rainmanx's Avatar
 
Join Date: Jun 2019
Location: Chicagoland
Posts: 50
Chirping noise over bumps

I finally was able to ride my machines! I have 2 2019 570 SP's. Sometimes one of them makes a chirping noise over bumps. Seems to do it more if you are off the throttle.

I can't find anything loose, and the other machine doesn't do it. They have the same miles, and this started on our first ride out.

Other than a nuisance, I don't find anything else wrong with it!

Thoughts?

Thanks!
rainmanx is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-17-2019, 06:59 PM
Premium Member
 
bp405's Avatar
 
Join Date: Sep 2011
Location: New York
Posts: 7,012
Normal just the EBS, engine breaking.

2011 Sportsman® 800 EFI
GURU front brush guard
GURU rear brush guard
Polaris front lock n ride cargo box
Polaris rear rack extender
Warn RT 3.0 winch w/amsteel synthetic line
Viper aluminum haus fairlead
Polaris front spring adjusters
Ricochet a-arm guards
Ricochet full frame skid plate
ITP T-7 beadlock 14" w/OMF inner rim guards
Maxxis big horn 2.0 26x9 front
Maxxis big horn 2.0 26x11 rear
QSC clutch kit
EPI HD springs front n rear
ODI rogue 130mm grips
Ultraseal commercial grade tire sealant (front)
Highlifter tire sealant (rear)
CTEK 3300 battery maintainer
added 7 zerks
beefed up wiring harness
OGIO rear bag
ROTOPAX 1gal. + 2gal. gasoline can
Jccapri bushing kit
Kolpin Over Fenders
Rigid Industries E-Series 10" flood
Walker Evans struts
NGK Iridium's (2,500 miles on Champion's and they looked great!)
Odyssey Extreme battery PC545

2018 Sportsman® 570-T
2019 Aluma® A8818
2020 Outlander® 1000R XXC (on order, ETA mid-Sept)
bp405 is online now  
post #3 of 5 (permalink) Old 08-19-2019, 03:58 PM Thread Starter
ATV Enthusiast
 
rainmanx's Avatar
 
Join Date: Jun 2019
Location: Chicagoland
Posts: 50
Now it's doing it with the throttle on. Only one of them. Going to take it in.
rainmanx is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 08-19-2019, 05:14 PM Thread Starter
ATV Enthusiast
 
rainmanx's Avatar
 
Join Date: Jun 2019
Location: Chicagoland
Posts: 50
I found the intake and exhaust ducts for the belt flopping away hitting stuff on both of them. Looks like at one time they had a screw, but now use wire ties.

I wire tied them down.
rainmanx is offline  
post #5 of 5 (permalink) Old 08-19-2019, 05:25 PM Thread Starter
rainmanx is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman 570

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome