Polaris Digital Display software - Polaris ATV Forum
Polaris Sportsman XP 1000 Discuss the Sportsman XP 1000 and Sportsman Touring XP 1000 here.

 1Likes
  • 1 Post By bitNine
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-30-2017, 06:41 AM Thread Starter
Extreme ATV Enthusiast
 
bitNine's Avatar
 
Join Date: Jul 2015
Location: Denver, CO
Posts: 120
Polaris Digital Display software

I just updated my XP1000 PIDD to the latest software from RideCommand (Dated 9/20) and it totally broke my display. Boots up and everything, but then after a few seconds it comes up with a message saying "UNABLE TO CONFIGURE. PLEASE SEE DEALER", blocking more than half the screen, making it almost completely unusable. Planning on a huge trip tomorrow, and now I'm screwed.

Anyone happen to have a PIDD update for the 4.3 screen prior to 9/20? You can't download older versions off the RideCommand site, and wouldn't it figure that I had an old version on my USB stick, and of course I overwrote it.

Here's a video I took to send to RideCommand:

Not sure what else to do to get it working for tomorrow's ride. Ugh...

2015 Polaris Sportsman 1000 LE
2013 Polaris Sportsman 550
2014 Polaris RZR 800

Last edited by bitNine; 09-30-2017 at 07:51 AM.
bitNine is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-30-2017, 05:05 PM
Extreme ATV Enthusiast
 
trusselo's Avatar
 
Join Date: Oct 2016
Location: Fort McMurray
Posts: 204
Garage
Support
phone
1-800-polaris

======================
2015 Sportsman XP 1000 PPCamo
3x 100W HID light kits - Wireless Winch
RAM Camera Mount from gpscity.ca
Tigertail from FortNine.ca
2 inch lift - 4 inch spacer kit - Fender Flares
Heated Seat kit & Camo seat skin
Heated Hand & Thumb Kit - 12" Cree light bar
Cecco Frame Braces - AMSOIL Front Drive Fluid
Dalton Clutch kit - Triangle ATV Stealth Snorkel
29" Traxion ICE Gripper MAX Studded Tires
======================
In progress ... reverse lights, turn signals and horn
Wish list.... HMF exhaust / re-flash
trusselo is offline  
post #3 of 8 (permalink) Old 09-30-2017, 05:10 PM
Extreme ATV Enthusiast
 
trusselo's Avatar
 
Join Date: Oct 2016
Location: Fort McMurray
Posts: 204
Garage
the current version on https://ridecommand.polaris.com/en-us/ridecommand is 09/30
looks like they already released something newer (fixed maybe).

https://s3.amazonaws.com/riderx-pidd...ded.mapInstall

======================
2015 Sportsman XP 1000 PPCamo
3x 100W HID light kits - Wireless Winch
RAM Camera Mount from gpscity.ca
Tigertail from FortNine.ca
2 inch lift - 4 inch spacer kit - Fender Flares
Heated Seat kit & Camo seat skin
Heated Hand & Thumb Kit - 12" Cree light bar
Cecco Frame Braces - AMSOIL Front Drive Fluid
Dalton Clutch kit - Triangle ATV Stealth Snorkel
29" Traxion ICE Gripper MAX Studded Tires
======================
In progress ... reverse lights, turn signals and horn
Wish list.... HMF exhaust / re-flash
trusselo is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 09-30-2017, 05:30 PM Thread Starter
Extreme ATV Enthusiast
 
bitNine's Avatar
 
Join Date: Jul 2015
Location: Denver, CO
Posts: 120
Quote:
Originally Posted by trusselo View Post
Support
phone
1-800-polaris
Closed on the weekends, unfortunately.

Quote:
Originally Posted by trusselo View Post
the current version on https://ridecommand.polaris.com/en-us/ridecommand is 09/30
looks like they already released something newer (fixed maybe).

https://s3.amazonaws.com/riderx-pidd...ded.mapInstall
That's the ORV trails update date. They updated that on Friday. If you download the current update, the actual bin file which contains the software update is named "Polaris_TV480_2710562_20170920a.gciBin". So it looks like the software itself is dated 9/20, while trails are 9/30. Additionally, looking at that URL having "furious" in the path, I believe means it's referring to the 7" PIDD, not the 4.3" PIDD on older RZR and Sportsmans.

I tried a billion different things today to try and get it to go stop. Updated the trails themselves again. Even disconnected battery for an hour to try and reset ECU. Found another thread (AEM Infinity XP1K with interactive dash2.0 - Polaris RZR Forum - RZR Forums.net) where a guy had this problem while trying to install an AEM ECU on a RZR, and so I thought it might be ECU related. Nope. No dice.

What I believe has happened is that so few people have the PIDD on a Sportsman, that people like me have been forgotten and all the software dev focus is on the RZR, meaning testing on a Sportsman is back-burner stuff. They probably made some updates that didn't take into account some differences in the Sportsman ECU vs. the RZR ECU.

I'll tell you this... I'm an idiot for trying to update right before a ride.

2015 Polaris Sportsman 1000 LE
2013 Polaris Sportsman 550
2014 Polaris RZR 800

Last edited by bitNine; 09-30-2017 at 05:36 PM.
bitNine is offline  
post #5 of 8 (permalink) Old 10-01-2017, 06:37 AM
Extreme ATV Enthusiast
 
trusselo's Avatar
 
Join Date: Oct 2016
Location: Fort McMurray
Posts: 204
Garage
I've done similar things with other electronics, and yeah it sucks. i feel your pain.

======================
2015 Sportsman XP 1000 PPCamo
3x 100W HID light kits - Wireless Winch
RAM Camera Mount from gpscity.ca
Tigertail from FortNine.ca
2 inch lift - 4 inch spacer kit - Fender Flares
Heated Seat kit & Camo seat skin
Heated Hand & Thumb Kit - 12" Cree light bar
Cecco Frame Braces - AMSOIL Front Drive Fluid
Dalton Clutch kit - Triangle ATV Stealth Snorkel
29" Traxion ICE Gripper MAX Studded Tires
======================
In progress ... reverse lights, turn signals and horn
Wish list.... HMF exhaust / re-flash
trusselo is offline  
post #6 of 8 (permalink) Old 10-01-2017, 03:27 PM Thread Starter
Extreme ATV Enthusiast
 
bitNine's Avatar
 
Join Date: Jul 2015
Location: Denver, CO
Posts: 120
Problem solved!

I have no idea why. Pulled out toys this morning to load on the trailer, display still showed error. Got to our destination and pulled it off the trailer. After a few seconds I see a message that says something like, "Configuration complete! Rebooting now.", it then rebooted and all was well.

I guess it just needed to be moved around a little bit? Weird. Well, I guess this is here for anyone else who ever has the problem.
13_xxc likes this.

2015 Polaris Sportsman 1000 LE
2013 Polaris Sportsman 550
2014 Polaris RZR 800
bitNine is offline  
post #7 of 8 (permalink) Old 05-27-2018, 11:32 AM
Junior Member
 
ArtMac's Avatar
 
Join Date: May 2018
Posts: 1
Sorry to bump an older thread but I am in this exact situation. So far it has not corrected itself. Still giving it a chance but thought I would ask here if anyone had additional information.

Thanks,
Art
ArtMac is offline  
post #8 of 8 (permalink) Old 05-28-2018, 07:46 AM Thread Starter
Extreme ATV Enthusiast
 
bitNine's Avatar
 
Join Date: Jul 2015
Location: Denver, CO
Posts: 120
Quote:
Originally Posted by ArtMac View Post
Sorry to bump an older thread but I am in this exact situation. So far it has not corrected itself. Still giving it a chance but thought I would ask here if anyone had additional information.

Thanks,
Art
Man, that sucks. Support's suggestion was that they mail me a USB drive with the software on it. As if the version I had was corrupt. They're clueless. Maybe try flashing it again. All I can say is that I moved it around a bit, forward, backward, loading and unloading from trailer, and after we unloaded it all went back to normal.

2015 Polaris Sportsman 1000 LE
2013 Polaris Sportsman 550
2014 Polaris RZR 800
bitNine is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman XP 1000

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Polaris passes Milestone flyinghigh ATV General Discussion 10 08-07-2017 11:25 AM
polaris 570 2015 exhaut heating gab570 Polaris Sportsman 2 05-19-2017 10:58 AM
96 sportsman 500 throttle problems msmith55 ATV Repair and Maintenance 4 11-13-2016 08:00 AM
May 2016 - Polaris ATV of the Month Voting! Wreckless ATV of the Month 1 05-16-2016 07:02 PM
Welcome to the new Polaris ATV Forum! dascrow Polaris ATV News 2 09-20-2010 01:39 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome