2015 Sportsman etx barely will run, pops, stalls - Polaris ATV Forum
Polaris Sportsman Discussions for the Polaris Sportsman 90, 300, 355, 400, 450, 500, 550, 600, 700, 800, 850

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 09-30-2018, 04:41 PM Thread Starter
Junior Member
 
PaYankee's Avatar
 
Join Date: Oct 2016
Location: Newnan
Posts: 18
2015 Sportsman etx barely will run, pops, stalls

Hello,

I have a 2015 Sportsman etx 325cc that failed on me today. I was going down a trail and it just the engine bogged down and quit like the fuel was cut off.

It will fire back up but it is hard to keep it running. It will only get up to 2500 rpm while running like crap and you have to blip the throttle to get it there. It will only hold 2500 for a few seconds before dieing out. While it's trying to run like this the engine has a slight backfire popping noise and it shakes. Runs the same with air intake off. Runs the same with fuel tank cap off. Tried to run hours after it cooled down and it does the same thing. Will not move under its own power.
Suspecting a bad spark plug or tps, need advice.

Has fresh 93 octane gas. Ran 20 miles today before this happened.

Thanks all.
PaYankee is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 09-30-2018, 05:00 PM
Premium Member
 
bp405's Avatar
 
Join Date: Sep 2011
Location: New York
Posts: 7,042
Any codes?

2011 Sportsman® 800 EFI
GURU front brush guard
GURU rear brush guard
Polaris front lock n ride cargo box
Polaris rear rack extender
Warn RT 3.0 winch w/amsteel synthetic line
Viper aluminum haus fairlead
Polaris front spring adjusters
Ricochet a-arm guards
Ricochet full frame skid plate
ITP T-7 beadlock 14" w/OMF inner rim guards
Maxxis big horn 2.0 26x9 front
Maxxis big horn 2.0 26x11 rear
QSC clutch kit
EPI HD springs front n rear
ODI rogue 130mm grips
Ultraseal commercial grade tire sealant (front)
Highlifter tire sealant (rear)
CTEK 3300 battery maintainer
added 7 zerks
beefed up wiring harness
OGIO rear bag
ROTOPAX 1gal. + 2gal. gasoline can
Jccapri bushing kit
Kolpin Over Fenders
Rigid Industries E-Series 10" flood
Walker Evans struts
NGK Iridium's (2,500 miles on Champion's and they looked great!)
Odyssey Extreme battery PC545

2018 Sportsman® 570-T
2019 Aluma® A8818
2020 Outlander® 1000R XXC (on order, ETA mid-Sept)
bp405 is offline  
post #3 of 13 (permalink) Old 10-01-2018, 07:15 AM
Polaris ATV Legend
 
latebird's Avatar
 
Join Date: May 2014
Location: Illinois
Posts: 4,351
Probably the fuel pump went south
latebird is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 10-02-2018, 03:03 PM Thread Starter
Junior Member
 
PaYankee's Avatar
 
Join Date: Oct 2016
Location: Newnan
Posts: 18
No codes. Just put in a new spark plug. Does the same thing. Can't even get to run anymore. Fuel pump makes whiring noise on startup. Researched the fuel pump issue and found the info about the 570s, probably the same pump.

They have the same part no.

Last edited by PaYankee; 10-02-2018 at 03:28 PM.
PaYankee is offline  
post #5 of 13 (permalink) Old 10-04-2018, 08:38 AM
Junior Member
 
wenatchee's Avatar
 
Join Date: Jan 2014
Location: wenatchee
Posts: 16
Fuel pump.
wenatchee is offline  
post #6 of 13 (permalink) Old 10-04-2018, 03:10 PM Thread Starter
Junior Member
 
PaYankee's Avatar
 
Join Date: Oct 2016
Location: Newnan
Posts: 18
I ordered a new quantum fuel pump along with the 570 gas tank heat shield and right side panel close off kit.
PaYankee is offline  
post #7 of 13 (permalink) Old 10-04-2018, 03:58 PM
Junior Member
 
wenatchee's Avatar
 
Join Date: Jan 2014
Location: wenatchee
Posts: 16
Hey PaYankee, I did a quantum pump also. 500 miles/1.5 years since. All good so far. I was thinking about the tank heat shield and close off panel, but haven't yet. Probably do it when the pump goes out again. Actually like the heat during winter time, not so much during the summer though.
wenatchee is offline  
post #8 of 13 (permalink) Old 10-04-2018, 04:11 PM
Premium Member
 
bp405's Avatar
 
Join Date: Sep 2011
Location: New York
Posts: 7,042
Quote:
Originally Posted by wenatchee View Post
Hey PaYankee, I did a quantum pump also. 500 miles/1.5 years since. All good so far. I was thinking about the tank heat shield and close off panel, but haven't yet. Probably do it when the pump goes out again. Actually like the heat during winter time, not so much during the summer though.
My thoughts also!!! With the close off kit on the new 570-T we have it'll be interesting to see the difference between it and the 800 in the winter

2011 Sportsman® 800 EFI
GURU front brush guard
GURU rear brush guard
Polaris front lock n ride cargo box
Polaris rear rack extender
Warn RT 3.0 winch w/amsteel synthetic line
Viper aluminum haus fairlead
Polaris front spring adjusters
Ricochet a-arm guards
Ricochet full frame skid plate
ITP T-7 beadlock 14" w/OMF inner rim guards
Maxxis big horn 2.0 26x9 front
Maxxis big horn 2.0 26x11 rear
QSC clutch kit
EPI HD springs front n rear
ODI rogue 130mm grips
Ultraseal commercial grade tire sealant (front)
Highlifter tire sealant (rear)
CTEK 3300 battery maintainer
added 7 zerks
beefed up wiring harness
OGIO rear bag
ROTOPAX 1gal. + 2gal. gasoline can
Jccapri bushing kit
Kolpin Over Fenders
Rigid Industries E-Series 10" flood
Walker Evans struts
NGK Iridium's (2,500 miles on Champion's and they looked great!)
Odyssey Extreme battery PC545

2018 Sportsman® 570-T
2019 Aluma® A8818
2020 Outlander® 1000R XXC (on order, ETA mid-Sept)
bp405 is offline  
post #9 of 13 (permalink) Old 10-20-2018, 05:42 AM Thread Starter
Junior Member
 
PaYankee's Avatar
 
Join Date: Oct 2016
Location: Newnan
Posts: 18
I put the new fuel pump in and now the quad runs great!
PaYankee is offline  
post #10 of 13 (permalink) Old 10-20-2018, 06:09 AM
Extreme ATV Enthusiast
 
Berserker's Avatar
 
Join Date: Oct 2018
Location: WI&UP
Posts: 102
I can't believe the state of Polaris. Is the whole industry this bad? This is a 3 year old machine. Granted I don't know the mileage.

Mine is 13 years old, and still going, other than ECM catching fire. Ha. Mine doesn't leave property much, and miles are extremely low. My kaw SXS 2800 miles, has leaked and now using oil. I am still dissapointed with it, being only 7 years old.


I would think this forum would lean harder to the old machines, like mine or older, due to age. But it sure weighs hard to last few year, or less.


Lot of people take these deep off trails with miles to walk out, with no cell reception. I understand the later may bother you more.
Berserker is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Service manuals cookies ATV Repair and Maintenance 1119 09-10-2019 08:47 AM
Clutch Trevor Goodrum ATV Performance Modifications 4 09-13-2018 01:43 PM
hilliard clutch dbweathe ATV Repair and Maintenance 2 12-27-2017 07:28 AM
Part number for factory winch, 2013 sportsman 500 HO? Smokinu454 ATV Gear and Gadgets 4 11-28-2017 05:38 AM
Wheel bearing brands DAKOTAKIDD Polaris Sportsman 19 03-17-2017 09:51 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome