2003 Sportsman 400, Overcharging and No Tach. - Polaris ATV Forum
Polaris Sportsman Discussions for the Polaris Sportsman 90, 300, 355, 400, 450, 500, 550, 600, 700, 800, 850

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-08-2013, 02:06 PM Thread Starter
Junior Member
 
ColoradoRed's Avatar
 
Join Date: Feb 2013
Location: Lakeville, PA
Posts: 1
Exclamation 2003 Sportsman 400, Overcharging and No Tach.

I have searched these forums well without results that seem to fit my ATV: a 2003 Non-EFI Sportsman 400.

It overcharges about 18V around 3K RPM and sits at 13V at idle.
The tachometer does not work, it did sporadically at idle when this first began to occur.
If I run at raised RPM for a minute or more the speedometer needle flashes and the battery icon flashes as well.
No other problems with the machine at all.

I am not sure if it is the stator, voltage regulator, or if it is the CDI box.

If anyone has heard of this before, or knows how to help please let me know; I do not have spare cash to trial-and-error this one.
ColoradoRed is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-08-2013, 05:06 PM
Polaris ATV Legend
 
Bruce!'s Avatar
 
Join Date: Feb 2009
Location: Port Angeles WA
Posts: 20,001
Welcome to the board!



Bruce! is offline  
post #3 of 4 (permalink) Old 02-09-2013, 12:52 AM
Polaris ATV Legend
 
4getful2's Avatar
 
Join Date: Aug 2009
Location: illinois
Posts: 2,352
Take the battery out of it first and have it load tested, a faulty battery will cause an overcharge. If the battery tests ok,then check the connections at the voltage regulator, if those are clean, then it's time for a new regulator..
4getful2 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 02-09-2013, 04:17 AM
Extreme ATV Enthusiast
 
creekman's Avatar
 
Join Date: Oct 2012
Location: Breeds, IL
Posts: 373
had this happen to my 04 sportsman 400. it was a bad voltage regulator.
creekman is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Sportsman

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2003 500 overcharging i think xplorerman ATV Repair and Maintenance 1 02-25-2012 05:09 AM
2005 sportsman 400 overcharging porker ATV Repair and Maintenance 5 12-09-2010 06:19 AM
sportsman 700 overcharging JCarman ATV Repair and Maintenance 5 05-12-2010 11:53 AM
Help 06 sportsman tach will not work kellum410 ATV Repair and Maintenance 0 04-29-2010 07:58 PM
1999 sportsman 500 overcharging cavingoin ATV Repair and Maintenance 2 02-02-2010 07:26 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome