2013 850 XP Won't Start, Click, Click, Click - Page 19 - Polaris ATV Forum
Polaris XP The Polaris XP Forum. Discussions covering the new Polaris Sportsman XP 850/550

 9Likes
 
LinkBack Thread Tools Display Modes
post #181 of 326 (permalink) Old 03-13-2017, 02:22 PM
Premium Member
 
phil's Avatar
 
Join Date: Apr 2010
Location: Black Lake, NY
Posts: 2,328
Garage
Quote:
Originally Posted by 2013xp850 View Post
Phil, did you end up installing the DB starter/selenoid or was tour last problem with the "click" with the new parts?

Sent from my SM-G900W8 using Tapatalk
I purchased a DB Electrical starter/solenoid unit. Not sold as individual parts. I have not installed it.
What I had done was to remove the original starter, strip the coating (A real PIA), dissembled the starter/solenoid (finding not much, some moisture in the solenoid) reassembled and bench tested = OK. I put it in my basement freezer (well below zero) for the night and retested = OK. Installed it and next trip out with cold and snow for a 5 mile ride out and no problems. So, I have a spare $100 starter on the shelf.
I did not find any bad, or loose, connections while removing or installing the starter.
Going to have wait another year for those conditions now. I am pretty well convinced that the problem is with the starter/solenoid unit.

2015 Sportsman 850 in Sage Green
3500 lb. Polaris HD Winch
QSC Clutch Kit (from Ryan @ RVS Performance)
Odyssey PC925L-P Power Sports Battery
VIPair Windshield w/mirrors
HD ATV Gear Billet Pinion Cover
EPI HD Springs, Front & Rear
Cecco Frame Braces
27X9 and 27X11-14 STI Rocktane XD Rubber
Guru Bumpers, Front & Rear
Lock 'n Ride Front & Rear Boxes
Rhino Monster, Rear Box
Camoplast Tatou 4s Track System
Heated Grips and Throttle Control
Lowrance BAJA 540 GPS
SuperATV EZSteer 380
Various Mods for Ice-Fishing
phil is offline  
Sponsored Links
Advertisement
 
post #182 of 326 (permalink) Old 03-15-2017, 06:29 AM
ATV Enthusiast
 
2013xp850's Avatar
 
Join Date: Mar 2014
Location: Miramichi, NB
Posts: 34
I went for a ride last weekend at 5 Fahrenheit outside and I got the dreaded click click click about 20 some miles from home. I was able to heat up the starter a bit and it fired up right away. Possibly will have to carry a little butane torch to heat it up if it happens again

Sent from my SM-G900W8 using Tapatalk
2013xp850 is offline  
post #183 of 326 (permalink) Old 03-16-2017, 02:10 AM
Premium Member
 
phil's Avatar
 
Join Date: Apr 2010
Location: Black Lake, NY
Posts: 2,328
Garage
Quote:
Originally Posted by 2013xp850 View Post
I went for a ride last weekend at 5 Fahrenheit outside and I got the dreaded click click click about 20 some miles from home. I was able to heat up the starter a bit and it fired up right away. Possibly will have to carry a little butane torch to heat it up if it happens again

Sent from my SM-G900W8 using Tapatalk
You got it. What a PIA this issue is. Needto definitely troubleshoot this to know the issue is with the starter/solenoid unit; but here's the real fix, I believe: https://www.dbelectrical.com/product...P8HAQ#app-list

2015 Sportsman 850 in Sage Green
3500 lb. Polaris HD Winch
QSC Clutch Kit (from Ryan @ RVS Performance)
Odyssey PC925L-P Power Sports Battery
VIPair Windshield w/mirrors
HD ATV Gear Billet Pinion Cover
EPI HD Springs, Front & Rear
Cecco Frame Braces
27X9 and 27X11-14 STI Rocktane XD Rubber
Guru Bumpers, Front & Rear
Lock 'n Ride Front & Rear Boxes
Rhino Monster, Rear Box
Camoplast Tatou 4s Track System
Heated Grips and Throttle Control
Lowrance BAJA 540 GPS
SuperATV EZSteer 380
Various Mods for Ice-Fishing
phil is offline  
Sponsored Links
Advertisement
 
post #184 of 326 (permalink) Old 03-16-2017, 08:23 AM
Junior Member
 
arrowflinger09's Avatar
 
Join Date: Mar 2017
Location: Harrison Township MI
Posts: 12
Garage
Quote:
Originally Posted by phil View Post
Quote:
Originally Posted by 2013xp850 View Post
I went for a ride last weekend at 5 Fahrenheit outside and I got the dreaded click click click about 20 some miles from home. I was able to heat up the starter a bit and it fired up right away. Possibly will have to carry a little butane torch to heat it up if it happens again

Sent from my SM-G900W8 using Tapatalk
You got it. What a PIA this issue is. Needto definitely troubleshoot this to know the issue is with the starter/solenoid unit; but here's the real fix, I believe: https://www.dbelectrical.com/product...P8HAQ#app-list

I agree. I plan to swap out my stock one for this one just as a starting point. (no pun intended).

Just not sure what to do about the times by bike actually would crank but seem like it wouldn't get fuel (frozen line maybe?) - other than to drain and start running an additive. Just hate doing stuff and not being able to validate until crunch time.
phil likes this.

Arrowflinger09
arrowflinger09 is offline  
post #185 of 326 (permalink) Old 03-16-2017, 02:59 PM
Premium Member
 
phil's Avatar
 
Join Date: Apr 2010
Location: Black Lake, NY
Posts: 2,328
Garage
Quote:
Originally Posted by arrowflinger09 View Post
I agree. I plan to swap out my stock one for this one just as a starting point. (no pun intended).

Just not sure what to do about the times by bike actually would crank but seem like it wouldn't get fuel (frozen line maybe?) - other than to drain and start running an additive. Just hate doing stuff and not being able to validate until crunch time.
Definitely a real headache. Don't know about your possible fuel issue, but maybe start with some fresh fuel, easy enough to do.

2015 Sportsman 850 in Sage Green
3500 lb. Polaris HD Winch
QSC Clutch Kit (from Ryan @ RVS Performance)
Odyssey PC925L-P Power Sports Battery
VIPair Windshield w/mirrors
HD ATV Gear Billet Pinion Cover
EPI HD Springs, Front & Rear
Cecco Frame Braces
27X9 and 27X11-14 STI Rocktane XD Rubber
Guru Bumpers, Front & Rear
Lock 'n Ride Front & Rear Boxes
Rhino Monster, Rear Box
Camoplast Tatou 4s Track System
Heated Grips and Throttle Control
Lowrance BAJA 540 GPS
SuperATV EZSteer 380
Various Mods for Ice-Fishing
phil is offline  
post #186 of 326 (permalink) Old 09-03-2017, 01:09 PM
ATV Enthusiast
 
2013xp850's Avatar
 
Join Date: Mar 2014
Location: Miramichi, NB
Posts: 34
Did anyone install a starter from DBelectrocal on their bike yet? And do we have to put something like a rubber coating just like the original starter

Sent from my SM-G950W using Tapatalk
2013xp850 is offline  
post #187 of 326 (permalink) Old 09-03-2017, 04:20 PM
Junior Member
 
arrowflinger09's Avatar
 
Join Date: Mar 2017
Location: Harrison Township MI
Posts: 12
Garage
Quote:
Originally Posted by 2013xp850 View Post
Did anyone install a starter from DBelectrocal on their bike yet? And do we have to put something like a rubber coating just like the original starter

Sent from my SM-G950W using Tapatalk
I installed one on my 2012 850XP a few weeks back. It came pre-coated from DB. Very easy install just make sure you have the right size hex driver and some extensions. I also did about every other recommendation for the cold weather issues. Ill have to re-locate my notes as I've been meaning to post them back up here. I installed the DB starter, Polaris starter relay kit, Odyssey battery and some other stuff (Maintenance & lighting). I do feel as if the bike fires up a lot stronger than it did previously although my issues were purely cold weather related. I'm just anxiously awaiting a good hard freeze and ice fishing season to start testing her out.

Arrowflinger09
arrowflinger09 is offline  
post #188 of 326 (permalink) Old 09-03-2017, 05:14 PM
ATV Enthusiast
 
2013xp850's Avatar
 
Join Date: Mar 2014
Location: Miramichi, NB
Posts: 34
Quote:
Originally Posted by arrowflinger09 View Post
Quote:
Originally Posted by 2013xp850 View Post
Did anyone install a starter from DBelectrocal on their bike yet? And do we have to put something like a rubber coating just like the original starter

Sent from my SM-G950W using Tapatalk
I installed one on my 2012 850XP a few weeks back. It came pre-coated from DB. Very easy install just make sure you have the right size hex driver and some extensions. I also did about every other recommendation for the cold weather issues. Ill have to re-locate my notes as I've been meaning to post them back up here. I installed the DB starter, Polaris starter relay kit, Odyssey battery and some other stuff (Maintenance & lighting). I do feel as if the bike fires up a lot stronger than it did previously although my issues were purely cold weather related. I'm just anxiously awaiting a good hard freeze and ice fishing season to start testing her out.
Thanks for the info. I also did almost all the cold weather survival kit for the bike, starter is the last thing left on the list

Sent from my SM-G950W using Tapatalk
2013xp850 is offline  
post #189 of 326 (permalink) Old 09-11-2017, 02:17 PM
ATV Enthusiast
 
2013xp850's Avatar
 
Join Date: Mar 2014
Location: Miramichi, NB
Posts: 34
Well clumsy me. Got my new starter today. Took my old one off and before I could put the new one in, I dropped it and one of the bolts that's on the starter selenoid broke off...so now ordered a new one and the wait begins again

Sent from my SM-G950W using Tapatalk
2013xp850 is offline  
post #190 of 326 (permalink) Old 09-11-2017, 03:45 PM
ATV Enthusiast
 
2013xp850's Avatar
 
Join Date: Mar 2014
Location: Miramichi, NB
Posts: 34
And now I have a question...will the old selenoid fit on the new DB Electrical starter? Maybe a quick fix for a spare starter

Sent from my SM-G950W using Tapatalk
2013xp850 is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris XP

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Starter click. Olmickeyt ATV Repair and Maintenance 6 02-13-2014 06:08 PM
Click Click Click go you piece of crap ellis_dave Polaris XP 16 01-22-2012 10:53 AM
05 700 efi no start, just a click (moved from sportsman) dheffyMN ATV Repair and Maintenance 0 12-28-2010 05:25 AM
click dirt dog ATV Repair and Maintenance 6 11-09-2010 08:02 PM
Rear left wheel "click-Click-Click" in reverse? TimberRidge ATV Repair and Maintenance 5 08-30-2010 07:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome