Checking the cooling system - Polaris ATV Forum
Polaris Xplorer and Xpedition Discussions for the Polaris Xplorer and Xpedition

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-21-2019, 12:59 PM Thread Starter
Junior Member
 
Zseverns's Avatar
 
Join Date: Nov 2018
Posts: 2
Checking the cooling system

I have a 1997 xplorer that I am having an issue with the cooling system. The fan is not coming on and just wanting to know is there is a way to check what is working and what is not. Also what all do I need to check?
Zseverns is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-21-2019, 02:33 PM
Polaris ATV Legend
 
latebird's Avatar
 
Join Date: May 2014
Location: Illinois
Posts: 3,592
unplug the wires from the sending unit in the top of the radiator and touch them together with the key on - if the fan runs, the sensor is bad or it has not gotten hot enough to turn the fan on or the sensor is not immersed in coolant.

2006 Trailboss 330
2002 Sportsman 90
2005 TRX400EX (FOR SALE)
2003 LT-Z400 (needs engine work & is for sale)
2004 CRF250X
1971 Triumph 650 Bonneville (has 5 original miles)
1972 Triumph 650 Bonneville (undergoing restoration)
1979 Honda CBX (6 cylinder)
1970 Kawasaki G3SS 90cc Bushmaster
1976 Suzuki RE5 Rotary (not running & FOR SALE)
1981 Kawasaki KZ305-A
1981 Suzuki GS450T (undergoing repair & will be for sale when done)
1982 Kawasaki KZ750-H (FOR SALE)
1989 Honda VT1100C
2007 Vectrix VCTX Electric Scooter
1965 Montgomery Ward 3 1/2 HP Tecumseh Mini Bike
1970 Triumph T25 250cc Trailblazer
1968 Triumph 250cc Flat Tracker

Shop Owner and Mechanic with over 50 years experience
latebird is offline  
post #3 of 3 (permalink) Old 05-21-2019, 04:40 PM Thread Starter
Junior Member
 
Zseverns's Avatar
 
Join Date: Nov 2018
Posts: 2
Ok thanks I’ll try that
Zseverns is offline  
Reply

  Lower Navigation
Go Back   Polaris ATV Forum > Polaris Model Specific Discussions > Polaris Xplorer and Xpedition

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Polaris ATV Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Over voltage Keith338 ATV Repair and Maintenance 31 06-06-2019 07:52 AM
NGK plugs Happyman Polaris Sportsman XP 1000 36 04-17-2019 05:00 AM
Will this oil filter work (#2540086) - '14 Sportsman 850 Skippy850 Polaris XP 7 01-17-2019 07:56 AM
2015 Sportsman etx barely will run, pops, stalls PaYankee Polaris Sportsman 12 10-21-2018 04:38 PM
Fitting another model muffler to '00-'02 Magnum? RacerP Polaris Magnum 5 01-11-2017 05:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome