Polaris ATV Forum banner

acceleration

  1. aftermarket primary clutch for sportsman 850?

    Polaris XP
    My primary is jammed/broken on my 2011 sportsman 850 so I could either get it fixed or get a better aftermarket one. And i would rather get a new one if i can, and if its much better. I don't like the ''smooth'' acceleration on the 850, i put a QSC clutch kit and its better but still not like...
  2. Hello. I need help with my polaris trailblazer

    Polaris Trail Blazer
    I just bought a 2005 polaris trailblazer 250. It runs good and everything but I notice a problem when you first start the atv it's really accelerated and stays that way. The acceleration it will not come down? And because of that it will not change to reverse or to neutral.? And if you change...
  3. scrambler 850 2013 acceleration problems?

    Polaris Scrambler XP
    Hi I´m new here, I´ve been having some troubles with the accelerator, on the screen comes out a signal which means "blocked accelerator" but it is not!! when engine is on it does not regulate normally. I have unassembled accelerator cables and are just perfect, I took out and cleaned injectors...
  4. Acceleration from standstill

    ATV Repair and Maintenance
    Hey Guys. I'm pretty new to this Forum, never posted any threads yet but frequently visit to figure out issues on my atv. I have a 2011 Sportman 850XP EPS with 80hrs on it and my issue is when I start to accelerate from a standstill, it almost feels like the back wheels spin. Its hard to explain...
  5. 2012 400 H.O. Speed, Acceleration and Power

    Polaris Sportsman
    I was wondering if there is anything on the market to make my 400 H.O. more power full and or increase acceleration and speed. We have 2 400's both are 12's and when me and my dad race mine always seems to lack of all three. Mine has a K&N filter and my dads is completely stock. :cowboy:
  6. 94 Trail Boss Acceleration Issues

    Polaris Trail Boss
    hi im new here so forgive me if this question has been asked befor.. i have a 94 trail boss 250 that when at a stop requires you to pull the throttle pretty hard befor it starts to move.. is this normal? or is there a way i can "fix" the response time on this.. note that it has a brand new...
Top