Polaris ATV Forum banner
bogging down
1-10 of 10 Results
  1. ATV New Members
    Hey everyone, I’ve been following the site for awhile mainly old Polaris tech and trying to self diagnose my ATV. Installed new Tbap harness from OTB. Anyway, I’ve been having this issue with my ATV for a little while and I’m having a hard time figuring out what it could be. My idling rpm is...
  2. ATV General Discussion
    Hey guys I have a 2000 scrambler 500 4x4 when I got it it would only run on choke. I got a new carb because I dont know anything about fixing or setting a carb. It still wouldn't run so I tweaked adjustments and got it to run but only when I covered carb with my hand almost all the way. We found...
  3. ATV Repair and Maintenance
    Hi there, I’m new to this forum but it looks like there is a wealth of knowledge here so I figured that someone might have had this problem before and could help. I’m fairly new to owning ATVs and carburetors in general but I have a very good automotive background. That being said, this bike ran...
  4. Polaris Sportsman
    My sportsman 500 EFI is bogging out and backfiring. Some history. We bought the ATV used, it had been sitting for about 8 months. We went for a rip and after about 4 hours tipped it in a big puddle (over my knees) it started bogging out and backfiring. We towed it home and changed the fuel...
  5. Polaris Sportsman
    Hoping you guys could help. I have a 2011 Polaris sportsman 550 EFI with 300hrs on it. It is running rough and skipping at idle (when I can get it to idle) it sometimes looses power and dies on me while riding also. I have gotten codes 520193-7 and 168-3 but they are not showing up currently. I...
  6. Polaris Sportsman
    Was heading down a road and all of a sudden it started bogging out. Took the carburetor off, cleaned it, checked for spark. when putting carb back on, it would not start and still won't start. Any suggestions of whats going on?
  7. Polaris Sportsman
    Alright, new to this so I hope this works haha. Okay so I bought a xplorer 400 nd it ran great. Took it out to the mountains and such and it worked fine. one day it just just wouldn't go above like 20mph. It sounded like there was a rev limiter on it! I seafoamed it and nothing changed. It runs...
  8. ATV Repair and Maintenance
    I have a 91 Polaris Trail Boss (4x4) that I just recently put a new piston in. I bought it from a fellow who didn't know what he was doing and he broke a piston when he was trying to put a new one in. The compression is back up again with a new piston installed. Everything runs great, except it...
  9. ATV Repair and Maintenance
    I have a 91 350L 4x4 that runs great for about a 100yds and then starts to bog. Hold the throttle, it will bog and die as if it is out of gas. If you let off it idles fine. Idle around for a couple of minutes, throttle up again for about another 100yds, bogs down. It always starts right up and...
  10. ATV Repair and Maintenance
    I have a Polaris Xplorer 300 4x4 and I recently had the top end re-done. The first time I took it out, I ran it about ten minutes. After that, it looses power. It bogs down. When you put it in neutral, and rev it up, it acts fine. If you put it in gear, it doesn't go anywhere. You can push it...
1-10 of 10 Results
Top