Polaris ATV Forum banner
cluster
1-5 of 5 Results
  1. Polaris Sportsman
    Trying to figure out why the speedo doesn't work and display showing an E. Could it be as simple as replacing the Sensor? Need some advice, Thanks!
  2. ATV Repair and Maintenance
    I have a 2014 big boss and the gauge cluster is shot. Polaris seems to change a part number every couple of years just to keep things interesting I guess. I would like to know if a cluster from a 2012 will work. The plug ins are the same and all the numbers match on the screen. I figure...
  3. ATV Repair and Maintenance
    I purchased this roll over and I'm trying to get it back to riding condition. We are almost there. I had to purchase a new cluster for it and I'm not seeing the RPMs on the display. The gears and four wheel drive indicators work fine. Basically everything concerning the yellow info button on the...
  4. ATV Repair and Maintenance
    Hoping someone can help me out here. About two weeks ago I hopped on my ATV to go for a ride, started her up, after about 5 seconds the display shut off. The ATV still runs fine, the display just shuts off after I start it. If it is not running and just has the key on, the display will stay on...
  5. ATV Repair and Maintenance
    Hello All! Can anyone help? I have a 04 ATP that won't activate the AWD. The first thing I noticed was the cluster no longer indicated the gear in. Rest of cluster is fine. Also unit would not go into diagnostic mode. Here's the puzzle to me, If I (using a test light) ground out the drum...
1-5 of 5 Results
Top