Polaris ATV Forum banner

dead

  1. 2005 Polaris Sportsman 400 completely dead after rough start

    ATV Repair and Maintenance
    Hey all, Long time lurker, rare poster here. I need some assistance. I'm having a heck of a weekend with my ATV. First, I went for a 10 mile ride with a wasp nest between my legs (they built it under the wheel well) and was wondering why I was getting swarmed every time I stopped or slowed...
  2. 05 700efi electrical issue sitting duck.

    Polaris Sportsman
    Hello everyone. I am having issues with my quad. 05 700 twin efi. I was using the winch one afternoon and the battery light flashed on the gauge. So I stopped using winch. Revved up a lil bit and then died. No power. Battery tested good. Stripped down and inspected wires etc. my fuse block on...
  3. 2006 Sportsman 450 died first time out

    ATV New Members
    Hi, I am new to this forum. I just bought a 2006 Sportsman 450 and on my first trail ride today it died on me. The engine just stopped running suddenly and the instrument display went blank. The starter won't crank the engine and the instrument display is not turning on at all. The headlights...
  4. Battery Dead, runs but headlights dim

    Polaris Phoenix
    I rinsed off my quad lightly with water and it started running rough. After about 20 min. it started running fine again. Two days later the battery was dead. I was able to kick start it and it seemed to run ok, but the lights were dim and they did not brighten with I rev'ed it up. If this was a...
Top