Polaris ATV Forum banner

efi

  1. ATV New Members
    Hey everyone, I’ve been following the site for awhile mainly old Polaris tech and trying to self diagnose my ATV. Installed new Tbap harness from OTB. Anyway, I’ve been having this issue with my ATV for a little while and I’m having a hard time figuring out what it could be. My idling rpm is...
  2. Polaris Sportsman
    2005 Sportsman 800 EFI Have ongoing issues I cannot resolve. Replaced broken fuel pump and machine was running great. After two weeks of good use, while idling in my driveway it killed and wouldn't restart. Now will start and run for a few seconds but kills as soon as I touch the throttle...
  3. ATV Repair and Maintenance
    The ATV starts up and idles fine for as long as you’d like it to. If you very carefully and quickly feather the throttle ever so slightly you can build RPM up around 13-1400. But if you try to easy the throttle in it will shut off. Pulled the plugs out and unplugged the fuel pump and cranked the...
  4. ATV Repair and Maintenance
    G'day All, Have picked up a sportsman 500, believe it to be the 2007 deluxe efi model. Having trouble getting power to the fuel pump and injector and was wondering if there is any way to test the ECU and PDM before buying new. Ideally want to hear the motor running to know if its worth...
  5. Polaris Sportsman
    I got a 07 sportsman efi the fan comes on when it wants to not when it should which cause me to over heat at slow speeds and I got to turn the key x5 to the on position to get the fan to turn on I got a new thermister when I unplug it the fan runs I swapped the relays nothing I jumped the relay...
  6. Polaris Sportsman 570
    I have a sportsman 570 and when I attempt to start it in the cold it will start and raise to 950-1100 rpm than stalls. You try it again and the same thing for ten more tries and if you give it throttle for 5seconds it runs fine. Some times it will randomly start fine in one of the cranking...
  7. ATV Repair and Maintenance
    Within the last month my bike has died at idle. It doesn't matter if its as soon as I start the bike or after I've been riding it for an hour. It takes off as it should and seems to ride fine under throttle at all positions except idle. It also makes a "puff" sound before dying almost like a...
  8. ATV Repair and Maintenance
    Greetings, Easiest way to ask question: On the MAP Sensor pigtail plug, what color is in the middle? Detailed way to ask: Two of three wires (orange and purple) on the MAP sensor pigtail have corroded and broken off the pins of the connector. The yellow wire is in tact. I need to know what...
  9. Polaris Outlaw
    Hello all, My son's 2017 110 EFI started to become harder and harder to start. Once started seems to run fine for the most part. It seems to be flooding out at start up as you can smell gas heavily at the exhaust. Would a dirty injector cause this issue if it were stuck open? Has good spark...
  10. ATV Repair and Maintenance
    Hey guys, new to the forum and a new Polaris owner. I just bought this 05 Sportsman 700 EFI. I'm having some issues with the idle running very rough. It constantly backfires from the air intake. Sounds almost like popcorn. Any help would be greatly appreciated. Currently I have a can of Sea Foam...
  11. Polaris Sportsman
    A few days ago I got a steal on my second Polaris, a 06 500 EFI with just over 2500 miles, it was only $1000. The first day it had a few issues but was overall great. The next day it would start and idle nicely, but as soon as you touch the throttle it dies. I pulled the plug and it is soaked in...
  12. ATV Repair and Maintenance
    HI All, As mentioned in the new member post I bought a used 2006 sportsman 500 EFI. Bought it knowing of issues it had but the price was right so I figured why not. Last time I worked on a machine was a 98 xplorer 2 stroke. so I have a few questions, my thoughts and followup. Anything you can...
  13. Polaris Sportsman
    Hey guys. I have a 2006 Polaris Sportsman that have been fighting for two years now. I have had a lot of issues with this ATV and do not know what else to do. I have always had an issue with getting it to run for more then a couple days :motz: I have just replaced the t-bap as I read this is...
  14. Polaris Sportsman
    battery is good, will crank just not fire. tired starting fluid and nothing. ran perfect last week. took spark plug out and sparked first crank then nothing. every time the key is shut off then back on it will spark once. then nothing. any ideas or tests?
  15. ATV Repair and Maintenance
    Need help I have a 05 sportsman 700 efi, it bogs down at immediate throttle and actually backfires into the intake, idle runs ok need help asap!!!
  16. ATV Repair and Maintenance
    Need help I have a 05 Polaris sportsman 700 efi, it has no power and just bogs down at throttle and actually backfires into the intake need help asap!!! I have video I'll try to post to show details
  17. Polaris Sportsman
    I'm new to your forum but need some help... please I have a 2007 Sportsman 500 EFI and there isn't any power at all. I've replaced the battery, starter solenoid, since there are any fuses I've replaced the Power Distro Module and kill switch. I've checked the continuity at each of the grounds...
  18. ATV Repair and Maintenance
    Hey guys, how ya doin? So my Sportsman has been having this problem for the past few months and i just have the time to fix it now. So i start it up, it starts fine. I drive it roughly 5-10 feet and all power goes dead on the quad. i turn the key back off and on and i still have no power. I have...
  19. Polaris XP
    My XP doesn't want to start, although after about 10 minutes of cranking and giving it some throttle it will eventually start, run really rough until it warms up, and then once warm will only restart if you give it a bit of throttle. I didn't have this problem until I put it on a trailer and...
  20. ATV General Discussion
    I bought a 2012 Sportsman 850 XP off craigslist. Guy said there was nothing wrong with it. When I got it I noticed it would lag a lot when i pressed in the throttle. Guy said its been sitting and probably just needs to be rode. I took his word for it. It still continues to lag very bad when i...
Top