Polaris ATV Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-19 of 32 Results
  1. ATV New Members
    I have a 2005 polaris trailboss 330 2x4 with a bad ecm. Finding a used ecm, someone to repair it, or ordering new seems like a nightmare and a ton of wasted time. Is there a way to bypass it with installing a universal voltage regulator rectifier? I've already hardwired the new LED lights and...
  2. Polaris Scrambler
    Hey all, I recently had to replace the kill switch on my 400 Sport. I wired everything up as it was with the old kill switch. The quad started up just fine, with the switch in the RUN position. But it also starts in the OFF position too. Completely stumped. Anyone know what could possibly be...
  3. ATV Repair and Maintenance
    Having an issue : while machine is running and I switch on the lights or the fan(manual switch) the engine dies. I used to be able to turn the lights and/or fan on before starting and it would start and run but now it will also just die shortly after starting. I am getting a good charge to...
  4. ATV General Discussion
    Hey guys. I have a polaris 330 magnum 2005 which recently started smoking after start up.(electrical smoke, comes out of under the handlebars) I was wondering if you guys knew anything about that? The lights do not work and it doesnt have a battery in it. Could that be whats causing the problem...
  5. ATV Repair and Maintenance
    Hello all, I am having an issue with my gauge cluster on my bike. I noticed my battery started to die overnight and that it would ark when I tried connecting the cables to the battery. It is not the winch. I troubleshot and came to the conclusion that it is the gauge cluster because it only arks...
  6. ATV Repair and Maintenance
    I’m still hoping someone here can help out! dealer couldn’t help all they could do was plug in diagnostic program and tell me what code I’m getting that’s it! back story the atv was running fine no issues then one day I got the check engine light (speed sensor) and power steering light but at...
  7. Polaris Sportsman
    Hi all, just want to confirm that this is probably a bad connection near the relay and is not the relay. I have been surfing this issue and it appears that it is not a new one. My wife’s beast: 2008 500 HO Sportsman Problem: turn the key to start, clicks 3 times, display shuts off. Wait 10...
  8. ATV Repair and Maintenance
    Having problems with my polaris sportsman 500. Nothing works, when I turn the ignition key, the speedometer dosent work, not a sound anywhere its completely dead. It stood outside for some time and about a year ago it completely died. We got it draged into an garage, and I tried working on it as...
  9. ATV Repair and Maintenance
    Hi all, I am new to the forums and would first like to say hello. I have combed through these for my same problem and although i have seen them, the fixes the askers have found all do not work for me. It started out with this 94 big boss having to have a ritual of pressing the electrical...
  10. Polaris Sportsman
    I've had this Sportsman for around 5 years and love it but the person before me made a lot of electrical modifications. Of course, the speedo didn't work but they did the bypass to get AWD to still function. I decided to cave in and bought a new speedometer and speed sensor - which I hooked up...
  11. ATV General Discussion
    Last year, while working on the carb and trying to jump an 04 Sportsman 500, my father ran into some electrical issues. Quad started going haywire and turning over itself. Took the key out, still kept cranking over. Turned the kill switch on the handle bars off, still kept cranking over. The...
  12. ATV Repair and Maintenance
    Hi hope someone can help, working on a 2015 polaris sportsman 850sp. When i got it needed a trans which i replaced no problem bike ran fine. New trans in and bike wont start has a bad crank position sensor that is on order. Now since i got it the check engine light has been on and i was trying...
  13. ATV Repair and Maintenance
    I'm working on a 1986 polaris trail boss 250 and cannot get a spark to the spark plug. I have replaced the ignition coil, CDI, spark plug, stator, voltage regulator, reverse speed limiter, and every cable. I was reading through the service manual and the test of the stator said, "check between...
  14. ATV Repair and Maintenance
    HI. I am hoping someone could give me an idea where to start with this. I have a 2006 sportsman 500 ho fuel injected. Thought the battery was dead but turned out to be the starter. This is where my problem started. I tapped on the starter while turning it over, it started to crank very...
  15. ATV Repair and Maintenance
    Hi, my son has an '05 Phoenix (200), we had a problem mid summer with backfiring and idle issues which disappeared when we turned the headlight on. Assumed there was therefore an issue with the voltage regular. Replaced the regulator and it ran great (without the headlight on ;) ) for about a...
  16. Polaris Predator
    I have a Polaris Predator 500 with electrical wiring altered by the former owner, I was with him in service and has all right, the problem is that it stops at random, after 15, 20 km and after the first stop stops more often, especially it stops when the lights turn on. I thought it may be due...
  17. Polaris Sportsman
    Hi, I'm new here. I've had a lot of problems with my 2014 sportsman 400ho. Now I just changed the solenoid, and it starts. I go to put it in reverse and the starter engages ??? The guy I had working on it, cut out some fusible links. He replaced with wire that was 2 gauges smaller than the wires...
  18. Polaris Magnum
    I have a 98 425 magnum 4x4 and three of the four wheels spin in 4wd. The front left doesn't spin. The hub fluid was at the correct level and new. I took apart the hub and everything in there looks fine. The Hilliard clutch when turned pushes out the rods in it to engage the tire. The back plate...
  19. ATV New Members
    I just bought a 1997 Sportsman 400 with only 2500 mi. It definitely needs a new battery. It also appears that the charging system is not working. The 4x4 does not lock in when the button is pushed in and no lights work and I don't think the cooling fan works either, but I don't think I've gotten...
1-19 of 32 Results
Top