Polaris ATV Forum banner

electrical issue

  1. 2005 Phoenix - tips for determining cause of blown CDI?

    ATV Repair and Maintenance
    Hi, my son has an '05 Phoenix (200), we had a problem mid summer with backfiring and idle issues which disappeared when we turned the headlight on. Assumed there was therefore an issue with the voltage regular. Replaced the regulator and it ran great (without the headlight on ;) ) for about a...
  2. Randomly stops and blow

    Polaris Predator
    I have a Polaris Predator 500 with electrical wiring altered by the former owner, I was with him in service and has all right, the problem is that it stops at random, after 15, 20 km and after the first stop stops more often, especially it stops when the lights turn on. I thought it may be due...
  3. 2014 sportsman 400. Starter engages running??

    Polaris Sportsman
    Hi, I'm new here. I've had a lot of problems with my 2014 sportsman 400ho. Now I just changed the solenoid, and it starts. I go to put it in reverse and the starter engages ??? The guy I had working on it, cut out some fusible links. He replaced with wire that was 2 gauges smaller than the wires...
  4. 98 425 magnum 4wd issues. Front left won't turn.

    Polaris Magnum
    I have a 98 425 magnum 4x4 and three of the four wheels spin in 4wd. The front left doesn't spin. The hub fluid was at the correct level and new. I took apart the hub and everything in there looks fine. The Hilliard clutch when turned pushes out the rods in it to engage the tire. The back plate...
  5. New member with old Sportsman

    ATV New Members
    I just bought a 1997 Sportsman 400 with only 2500 mi. It definitely needs a new battery. It also appears that the charging system is not working. The 4x4 does not lock in when the button is pushed in and no lights work and I don't think the cooling fan works either, but I don't think I've gotten...
  6. 2012 Polaris Sportsman 500 H.O. -NO SPARK!-

    ATV Repair and Maintenance
    Ok I have bought a new battery and ignition coil and spark plug. Everything the Clymer manual says to "ohm" I have. I have not been able to remove the flywheel and check all that but the bike turns over and everything seems normal just NO SPARK. put new OEM coil/wire combo and plug, CDI BOX...
  7. 08 sportsman 800 stator test?

    2008
    Can someone please tell me how to test the stator and voltage regulator, I have a multimeter but am not very handy on how to use it or how to go about testing these 2 things. My wheeler has no reading on the tach and it doesn't seem to be charging. Any info would help before I start spending...
  8. what do you think?

    ATV Repair and Maintenance
    So I've got another question. If I've got a bad voltage regulator.. which I do. Would that make the 4x4 not engage? Seeing as the 4 demand requires voltage to the magnetic rings to function. Am I missing something else? Is there a way to tell if the magnetic coils are bad?..what are odds that...
  9. Electrical turns on for 20 sec. Then shuts off

    ATV Repair and Maintenance
    Hey guys I am new here... I have a 2005 polaris sportsman 500 ho. It has been a great bike and I have had no problems with it, however a few weeks ago I went out riding in a rain storm with the kids, played in a few puddles nothing deep and now I can't get the bike to start.... The electrical...
  10. ATV Kills when warned up. Does not start

    ATV Repair and Maintenance
    OK I have a challenge for you tech folks. I am out of answers. I have a 2004 1/2 sportsman 400. Once it gets warmed up it kills and will not start again. It can be idling or going down the road. Actually if I choke it it will start and run for a little while but will kill again. I need to let it...
  11. charge system not producing enough

    ATV Brakes & Suspension
    New to Forum...love it by the way! I use my sportsman to spray wheat trials...once the fan kicks on it doesn't take long for the battery light to start flashing...and the sprayer pump starts starving for power. Can anything be done to increase the electrical capacity? Could there be an issue...
  12. New Rider - Why has my Instrument Cluster Turned Red in Illumination

    Polaris Sportsman
    I have a new 2012 Sportsman 550. Currently has 7 hours on it. It's been 15 years since I enjoyed riding an atv. Took it out on a good ride only once so far and on short 5 - 15 minute rides around the neighborhood. I keep it garaged and toyed with it today for a little bit. Tonight I started...
  13. '07 electrical problem.

    Polaris Sportsman
    I recently drowned my '07 800 sportsman (water at handle bar level). I was able to start it ride it home. It started and seemed fine the next day but not the day after that. Now it will start if I jumper the starter solenoid but I have no dash lights and my winch doesn't work. I still have...
  14. electrical system problem

    ATV Repair and Maintenance
    I recently purchased a 1988 trailboss 250 it starts and runs fine but it's not charging battery any ideas on possible problem? I'm assuming since it runs that stator must be working. I connected up volt meter to battery connections all I get for voltage is 12+ volts and voltage drops off once...
  15. Won't start..no power

    ATV Repair and Maintenance
    I have had issues since I bought my 800 Sportsman Deluxe with the 20amp fuse that covers the radiator fan. It would happen after a few hours of riding. Yesterday I added an audio tube to my atv and now it's giving me the same issue like the fuse is blown, but the fuse is intact. My winch works...
  16. 2005 Polaris 500 ATP - ECM problem?

    ATV Repair and Maintenance
    Can anyone tell me if there is a way to test the ECM on a Polaris atv? I hate to buy one if it isn't the problem. My atv has no electrical power to anything and the battery is a new one. No lights, no power to anything. All connections seem good. We have 12 volts going into the ECM but only...
  17. Sportsman 90 No Power

    ATV Repair and Maintenance
    I have searched all threads fpr Sportsman 90 and couldn't find one to fit my issue. I have bought my daughter a 2004 Sportsman 90 for Christmas and I took the plastics off today to get it cleaned up a bit and after reconnecting the battery I have no power at all. No dummy lights, nothing. The...
Top