Polaris ATV Forum banner
electrical
1-19 of 56 Results
  1. Polaris Scrambler
    I have purchased a 1999 Scrambler 2 Stroke with pull start (no electric start). I have put in new gas, new spark plug, and new battery. When the battery is fully charged/plugged in, the quad starts up no problem. When I put it in the back of my truck and drive it to where I use it (10 minutes)...
  2. ATV Repair and Maintenance
    Hi all new to the page hoping for some help! I bought the machine off a friends brother. It had just 320 miles when I picked it up a few months ago. We rode out of Palisade MN for the 4th and it ran awsome all day. roughly 120 miles riding 2 up mud/water trail/sand no complaints... Until we...
  3. ATV Repair and Maintenance
    I have a 99' Polaris Xplorer 400 4X4 that was running well until one day it stopped mid-ride and I can't get it started again... When it stopped I tried and tried right after and it kept getting weaker and weaker, like the battery was dead. I charged the battery, no luck. Went to advance and...
  4. ATV Repair and Maintenance
    I have a 99' Polaris Xplorer 400 4X4 that was running well until one day it stopped mid-ride and I can't get it started again... When it stopped I tried and tried right after and it kept getting weaker and weaker, like the battery was dead. I charged the battery, no luck. Went to advance and...
  5. ATV Repair and Maintenance
    I just bought a 2017 Sportsman 450 HO from a private party - only 40 engine hours on it, but its out of warranty. The battery was dead after we took it out riding for a few hours and I had to charge it. I took the battery to NAPA and they said its fine. I read a forum on here from 2013 on how...
  6. ATV Repair and Maintenance
    The battery for my 2004 polaris sportsman 500 HO was recently put in backwards and began smoking when the key was turned. I have switched the battery and put wiring back to make sure it is correct. I then turned the key and found that I still have power to the machine and it does crank. The...
  7. ATV Repair and Maintenance
    Just bought a used 2013 sportsman 500 ho, this is my first 4x4 quad. Worked fine for a month and battery went dead and nothing would power on. Changed battery and while tightening the positive terminal, my wrench touched the ground and made a spark. I turned the ignition on for power to my...
  8. ATV Repair and Maintenance
    I have a 2005 phoenix 200 I am looking for a wiring diagram. I was having problems getting the machine to start. It was just clicking. I purchased a new battery and charged it overnight. Still nothing but clicking. I had my son look at it and he said it may be the starter or solenoid. When he...
  9. ATV Repair and Maintenance
    I have an '03 Magnum 330 and the CDI box burned up, which I now know is a common issue with this CDI box. Problem is they are not cheap, $250. A '02 Magnum 325 CDI box is the same physical size, has the same connection and is 200 bucks cheaper ... but is a different part number. Can the 325...
  10. ATV Repair and Maintenance
    Ok, been having overcharge issue for a couple weeks now. I bought new ecm thinking it was voltage regulator as battery was metering at 16-18 volts at 3000-4000 rpm. After new ecm (regulator is built in on this model year), same overcharge issue. I tested stator legs and they are ALL showing a...
  11. ATV Repair and Maintenance
    I have recently acquired a 2006 Sportsman 450. The ECM was replaced on recall in August 2015 (previous owner, confirmed by dealer). As luck would have the NEW one also crapped out. The internal voltage regulator, inside the ecm of course, is not working and battery over charges to 18V at 3000...
  12. Polaris Sportsman
    Hello, My name is Steve, thanks for allowing me to join this group, I have a 2002 Polaris Sportsman 700, when you turn the key the starter seems like its binding up, well it burned up the starter, like smoke coming off it burned up, so i changed the starter, the bendix, and the solenoid, still...
  13. ATV Repair and Maintenance
    If the pod mount receptacle receiver is plugged in the two leads it will blow my ACCY fuse also my winch will not work, if i unplug the leads to the pod mount receptacle receiver fuse will not blow and winch will work. I thought i found the problem because the positive terminal was loose. i...
  14. Polaris Sportsman
    The other weekend while riding my atv I had the headlights on and while the four wheeler was at idle and I was using the lights to find some things on the ground they just went out and won't turn back on. I have checked the fuses under the front rack and they are all good. I have not checked to...
  15. Polaris Predator
    I have a 2005 predator and it all of a sudden won't start. I can push/pull start it but my starter solenoid keeps clicking. I put a new solenoid in it and it still keeps clicking. Once in a great while it will barely turn over. HELP????
  16. Polaris Sportsman
    Hey guys, I am a new member and just happened to find this website today!! The problem I am having with my ATV is this - When I turn the key nothing lights up, the battery is fully charged. The battery has some history of needing a good charge from time to time, but I only ride it about one...
  17. ATV Repair and Maintenance
    I have a 01 sportsman 500 I just bought. Problem is with speedometer main harness unplugged atv starts up and runs awesome but if you plug in speedometer atv shuts off immediately but all lights and functions of speedo works fine engine will crank just no fire. Unplug speedo main harness and...
  18. Polaris Sportsman
    Hey everyone, I have been having running issues with my 2004 Sportsman 500 HO. I start it, but it will only run for about 5 seconds then it dies. The only way I can get it to start back up again is to flip the kill switch off then on again, but it still only runs for a short amount of time. I'm...
  19. ATV Repair and Maintenance
    hi. im having electrical problems with my 04 Trail boss 330 the battery voltage drops dramaticaly when RPM rises...... resulting in the battery not charging. idle volt: 14.5v when revving: ca 9v and lately the ATV has started backfiring like crazy... could this be a faulty CDI box? any...
1-19 of 56 Results
Top