Polaris ATV Forum banner

engine bogs

  1. 2000 Sportsman 500 Problems

    ATV Repair and Maintenance
    I have a 2000 Polaris Sportsman 500. A year or so ago we got it running after replacing the kill switch. It ran great but after some use for a couple months it got a flat tire and for some reason we just forgot about it and it sat for some time. Before it sat i replaced the gas cap, fuel...
  2. 04 500 HO loss of power

    ATV Repair and Maintenance
    Hey Guys, new to the forum so hopefully some of you can help me out. I just bought a 2004 sportsman 500 HO from an older man who bought it brand new. Not a lot of maintenance had been done to the wheeler because he only used it to plow his driveway. It actually only has 500 miles on it. All...
  3. 2000 xplorer 400 Starting/idling/running issues

    ATV Repair and Maintenance
    I got the 400 from a guy who hit a deer with it he said. broke his arm and collar bone and wanted it gone. most of the plastics were cracked or broken but it ran great....for a while. Now I have to remove plug, and spray carb cleaner in to get it to start, then it wont idle I have to hold slight...
  4. 06 sportsman 500 engine troubles

    Polaris Sportsman
    I aquired the bike in April and right off the bat I needed to fix the stator wires that had rubbed through, it runs, shows rpm,s and charges the battery so it's working fine, have a new plug in it, when I drive the bike from idle at 1100-3000 rpm it runs fine. From 3000 - 4000 rpm it sputteres...
Top