Polaris ATV Forum banner

fan not working

  1. 07 sportsman efi fan problems please help!!!

    Polaris Sportsman
    I got a 07 sportsman efi the fan comes on when it wants to not when it should which cause me to over heat at slow speeds and I got to turn the key x5 to the on position to get the fan to turn on I got a new thermister when I unplug it the fan runs I swapped the relays nothing I jumped the relay...
  2. Fan problem

    Polaris Sportsman
    Hi guys I need some help. My 2010 sportsman 500HO fan wont come on. The fan works when I hook it direct to the battery. So far ive replaced the 10 amp breaker it looked pretty rough there was a hole in it and water dripped out. I also tried unplugging the heat sensor nothing. What should I...
  3. 2009 Sportsman 500 H.O. fan issues

    Polaris Sportsman
    While riding the other day I got the message saying HOT ENGINE. I shut down the machine and let it cool for awhile before restarting and took it easy on the way back to the trailer except for a couple of deep holes I just couldn't resist. When I got home I hooked the fan up to a battery and it...
  4. 01 sportsman 500 ho fan won't start

    Polaris Sportsman
    I have an 01 sportsman 500 ho. The fan won't start. I know the fan works because if I bypass and hook directly to the battery it will run. I replaced the temp sensor and the circuit breaker in the front of the machine. Any other suggestions?
  5. Fan coming ON and after a few seconds turns OFF

    ATV Repair and Maintenance
    Hi guys I need to know if anyone of you knows what can cause the fan to run and stop after a few second.. This is causing the bike to overheat. Comments are more than welcome, thank you.
Top