Polaris ATV Forum banner
fix
1-6 of 6 Results
  1. ATV New Members
    Hi, I see motor mounts are a common issue on these machines..... can someone tell me of a better solution to repair these than buying a new set of the same problematic parts? Did they issue a recall im unaware of? My machine has 1000kms on it always washed after a ride... stored indoors...
  2. ATV Repair and Maintenance
    Ab a year ago our Sm 500 was rolled. since then on the screen it says engine hot and hot oil. It says this even before the machine is turned on after sitting for days. Any suggestions? thanks!
  3. ATV Repair and Maintenance
    Hello all. I have a sportsman 570. It will crank but will not fire up or stay running. new spark plug New battery (says the new one is low, even on charger) the fuel pumps pressure is at 55 psi. Any tips on what the problem is and how to fix it?? Thanks!
  4. ATV Repair and Maintenance
    Hello all, I have a knocking sound coming from my 2015 sportsman 570 efi.. I just bought it. The sound only occurs while rolling really slow, or going over bumps. It sounds like something is loose, but I can’t seem to find anything loose. I’ll attach a video of the sound.. if anyone has any...
  5. ATV Repair and Maintenance
    I have a 1999 Polaris scrambler i bought off a guy and the gears are backwards? So reverse is now hi range and hi range is now reverse? If anyone knows how to fix that it would be greatly appreciated. thanks
  6. ATV Repair and Maintenance
    On my sportsman Ijust picked up the speedo isn't working. Its all wire no cable but is dial type speed display. That isn't working but all other display stuff does. Inside the dash the big plug that goes into the back of speedo there is a blue wire with white stripe that is pulled out of the...
1-6 of 6 Results
Top