Polaris ATV Forum banner

no power

  1. Polaris Sportsman
    My 2004 (manufactured 2003) Polaris sportsman 500 was operating normally, the next time I went to use it there was not power to anything except high headlights(low headlights didn’t work before this issue). I double checked that the battery was charged. I tested all three of the self resetting...
  2. ATV Repair and Maintenance
    I have a 2015 sportsman 1000 xp. First I was having some power steering issues. EPS light was on and power steering was not working. I check the relay and it was still good. I then noticed that when I put the relay back into the fuse box it work fine. Tried again the next day and it wasn’t...
  3. ATV Repair and Maintenance
    Hi and thanks for reading. Any al all help will be greatly appreciated. My Ranger 700 EFI runs but not well. When this started I trouble shot through and repaired several issues each time thinking I had solved it but to no avail. Fuel pressure was lower than acceptable range so pump was...
  4. ATV Repair and Maintenance
    I have a 2015 ranger xp 900 high output It has about 53 hours and 259 miles It was running fine when I parked it with a full tank of gas then I went out this morning and the check engine light is on and it's in limp mode. it is only going 10mph in high and under 5 mph in low only going to 3600...
  5. Polaris Predator
    i have a wiring problem with my predator. i recently rebuilt it and had it running excellent. one night i noticed that the brake light sensor wires had broke off and while riding the wires were touching the brake lever making the headlights flicker and spark. once i noticed i was heading back to...
  6. Polaris Outlaw
    Hello, I'm new here, this is my first polaris, this bike has been sitting around a lot, I just got it and it has a brand new battery(full charge), I have checked all grounds, fuse links, fuses, can't find any broken or damaged wires, the engine will turn over when I cross the silanoid, but it...
  7. ATV Repair and Maintenance
    I went to the dunes with some buddies last fall. After riding for about an hour, my carb had problems. It would idle, but that's all. Any load on the engine and it would bog out. I limped it back to the trailer using the choke. I tore the carb apart and cleaned it. After putting it back...
  8. Polaris XP
    I have a 2013 sportsman 850 that is overheating. It started from the very first ride the hot light will come on and engine goes into limp home mode. i have not acctually let it get to the point where antifreeze comes pouring out but i can tell it is exteamly hot. the fan works but only for a...
  9. ATV New Members
    Hey my 04 sportsman 400 will no start. There is no power when key is turned on. The battery was fine yesterday and I even had a charger on it after to try. The pull cord will not work either it doesn't catch it just pulls out all the way super easy. Any help would be great thanks.
  10. ATV New Members
    i have a 2000 polaris 325 that i got given to me. the guy i got it from said that it had carb problems and that it ran great before the carb started flooding over then he parked it about 8 months ago. so i brought it home tore it apart and cleaned the carb and replaced the needle valve and seat...
  11. ATV Repair and Maintenance
    On my sportsman Ijust picked up the speedo isn't working. Its all wire no cable but is dial type speed display. That isn't working but all other display stuff does. Inside the dash the big plug that goes into the back of speedo there is a blue wire with white stripe that is pulled out of the...
  12. ATV Repair and Maintenance
    Hey there... Interesting thing happened last time i went to start the bike up. No power to the head unit. I can still turn the key and run the bike but there is literally 0 power to the head console unit. Ive checked all the fuses. Any suggestions? Thanks :hmmm:
  13. ATV Repair and Maintenance
    2002 Sportsman 500 RSE Runs like crap I was riding on Friday and noticed that when I feathered the throttle the machine would hesitate and sputter a little,but if I goosed it,it would take off and run fine.I went out again on Sunday,and it kept getting worse as I rode.After about 15 miles it...
  14. ATV Repair and Maintenance
    Since you guys have been so helpful in fixing my last few problems.... 1996 sportsman 500 I changed my belt last fall and thought I had fixed my problem. It started right up today and runs good, idles fine,but I do not have much power. In fact i feel i could be passed by a turtle. The carb...
  15. ATV Repair and Maintenance
    My 2009 Trailboss 330 just died on me. Ran fine one second and died the next. No lights or power. At first look, I assumed a battery issue. We put a working battery on it and it made zero difference. I brought it to a repair guy who is a former Polaris Certified Technician. He has hiw own...
  16. Polaris Sportsman
    OK. I'm stumped. I have an 02 sportsman 700 twin. It has a new battery. It does not start. It has intermittent power to dash, lights, starter etc. I do not know why it is acting this way. I have checked battery connections, solonoid and power to starter switch. I can't intentionally get power to...
  17. ATV Repair and Maintenance
    This bike has been sitting up for years. as far as I can tell it's a 2007 sportsman 90 4 stroke I went through the fuel system including the carb. cranks fine, rough idle but I can't tune it due to that fact that it won't power up past an idle. It acts like the rev limiter is out of whack...
Top