Polaris ATV Forum banner

over heating

  1. 2007 Sportsman 800 overheating

    ATV General Discussion
    Hi all, I appreciate there are some other threads out there on this topic, but looking to maybe get some fresh views. I will admit I am new to Polaris. I have been a Honda guy for years, so trying to learn on the fly about the differences. I recently picked up a 2007 800 EFI with 1500 miles...
  2. please help! sportsman xp over heating

    ATV General Discussion
    I have a 2011 sportsman xp eps 850. I changed three axles, the front frop shaft, replaced the rear brake, put in new pads, cleaned the clutches and changed all the fluids. now it sais is over heating after about a half hour of riding. so the rad is sparkly clean, I changed the tem sensor, and...
  3. 850 sportsman fan circuit breaker?

    ATV Repair and Maintenance
    All right every where I've searched to solve my problem. (limp mode with over heating light). Seems to point to a circuit breaker for the fan. Where in the heck is it at on a 2014 850 sportsman xp eps.... I've seen pictures on line and it seems to be attached to the wiring harness under the...
  4. 850 sportsman limp mode not overheating

    ATV Repair and Maintenance
    I've seen all sorts of answers on here but does not exactly sound like my problem. My sportsman has less than 100 miles. It's been doing this off and on since about new. Just got unbearable Sunday. Every once and awhile not ever trip the hot light would come on and I'd go into limp mode. Does...
  5. 2002 700 sportsman, over heating

    ATV Repair and Maintenance
    I have an 02 Sportsman 700 and in the last few days I've all of a sudden encountered an over heating issue. Is this common? Is there a remedy, or something I should be looking for. I've also noticed sometimes the cooling fan kicks on but sometimes it dont, what could be my problem? Any help...
  6. 2012 sportsman 500 overheating

    ATV Repair and Maintenance
    Hi folks - just bought a new sportsman 500 yesterday. Got it home and rode it for about 15 minutes and the hot engine light came on. Let it cool off and rode it again - same thing. Took it back to the dealer this morning and they diagnosed a bad sensor and replaced it. Got it home this evening...
  7. New and need help with cooling system

    ATV New Members
    I just recently bought a sport 400. This is my first quad, when i test drove it was my first time riding a quad. I have done minor work on cars but that's it. When I first got it I thought that it had carb problems(at least that's what a buddy said the issue could be). I cleaned it out,replaced...
Top