Polaris ATV Forum banner

rough idle

  1. ATV Repair and Maintenance
    I’ve had this 2004 sportsman 700 late model for about a year now and it’s been through multiple carb rebuilds. I’ve got it to where it’s as dialed as it’s ever been but it’s never perfect. Sometimes it idles up at 1400-1500 rpm, sometimes it’s down at 800-900 rpm, and sometimes it’s perfect at...
  2. Polaris Sportsman
    Hoping you guys could help. I have a 2011 Polaris sportsman 550 EFI with 300hrs on it. It is running rough and skipping at idle (when I can get it to idle) it sometimes looses power and dies on me while riding also. I have gotten codes 520193-7 and 168-3 but they are not showing up currently. I...
  3. ATV Repair and Maintenance
    We have a 4x4 Ranger with rough idle, and the service manual recommends a leak-down test. However, there's no guidance on how to find top-dead-center. Bumping the starter and inserting something in the spark plug opening is inconclusive, as it seems like the rotation always lands at the same...
  4. ATV Repair and Maintenance
    I have a 2009 Sportsman 800 H.O EFI that all the sudden started running like junk. The machine is bone stock and only basic oil changes have been done to it. I have read a million post about the TPS and TBAP sensor harnesses are awful quality, so I started there and tested everything. I am...
  5. ATV New Members
    I've got a 2004 Polaris 90 I got cheap and am trying to rehabilitate for my kids. When I first got it, it would only run with the choke on. I pulled the spark plug which was black but in surprisingly good shape. The air filter was also in pretty good shape. Pulled the carb and it looks brand...
  6. ATV Repair and Maintenance
    Hi and thanks for reading. Any al all help will be greatly appreciated. My Ranger 700 EFI runs but not well. When this started I trouble shot through and repaired several issues each time thinking I had solved it but to no avail. Fuel pressure was lower than acceptable range so pump was...
  7. ATV General Discussion
    Hello all, Very new to the online posting scene so apologies in advance if I am out of line here. I have read a ton of stuff on this subject and special thanks to AKStew for all his headaches and postings! My problem was similar in my 07 800 Sportsman. I checked the TBAP harness / sensor...
  8. ATV Repair and Maintenance
    Hey guys, Slight problem on my 04 500, It seems like it wont idle at all unless the engine is warm. And its very hard to start. Normally always have to use the pull start to spin the engine fast enough to get it running. (could be another problem with my starter) Any who, it does it at all...
Top