Polaris ATV Forum banner

stalls

  1. Stalls When Accelerator Pushed

    Polaris Outlaw
    Hi my son has a 2016 Outlaw 50. I brought is second hand last year and it run and drive fine. A few months back it has developed a problem where it starts ok, idles fine but when the accelerator is pressed it stalls? Strangely in on a stand and the rear wheels of the floor, I can press the...
  2. Ace 570 stalls at 15 mph

    Polaris ACE
    Bought a used 2015 Ace 570 end of last year rode it a few times in the yard this winter. Got it out today to ride around and it stalls out at around 12-15 mph every time. The check engine light comes on the machine shuts down. No flashing codes on the check engine light just a steady light on. I...
  3. If its not one problem, it's another.....

    ATV Repair and Maintenance
    So here's where I'm at right now. 2007 polaris sportsman 500 efi. When in park, it only starts when the brake is pulled in. After starting, it starts to stall, and sometimes just dies out altogether when in reverse. The speedo needle is all over the place, and the battery light is flashing. What...
  4. 06 hawkeye information

    ATV Repair and Maintenance
    Hello all. I am an ASE certified automative repair shop owner ("oh great... here we go" says everyone... lol) The only reason I say that is to let anyone know who may think that they have info over my head to let me have it anyway. I am having an issue with my 06 hawkeye. It's having a...
  5. 500 dies after warming up

    ATV Repair and Maintenance
    HI, I have a 2004 ATP (Sportsman) 500 HO and it dies after it warms up. The fan may come on once or twice then it shuts down. Can restart but dies right away. Let it cool down and we're back going but stops again once it heats up. No hot light. New "etc", carb (needed it), oil, antifreeze...
Top