Polaris ATV Forum banner

starting issues

  1. 2000 xpedition 425 starting problems

    ATV New Members
    Hi all I'm new to this site from Manitoba Canada The problem im having is that when i press the start button all i hear is a clicking sound engine wont turn over. the starter is newly installed last fall have also replaced the battery and the starter solenoid this spring...when i took the atv...
  2. 2006 sportsman 500 ho efi not wanting to start.

    ATV Repair and Maintenance
    Hello. I have a 2006 polaris sportsman 500 ho efi and it died on me a few days back. Once I got it in my shop I found that when I would turn the key on nothing would happen. I put a charger on it and still nothing. I pulled the plastics off it and was checking voltage and found that I have...
  3. 07 outlaw 500 turned key NOTHIN'. Please help!

    Polaris Outlaw
    I have a 07 outlaw 500. Worked awesome, next day went to start it. Nothing. No lights. No sounds. Nothing. Checked battery. Battery is good. Cleaned off all connections, reconnected them. Still Nothing. I don't know much about electrical at all so any suggestions are muchly appreciated.
  4. 89 2 wheel drive starting problem

    ATV New Members
    I am new to the site so I hope this works. I just recently purchased a 1989 2 wheel drive cheap. It had a burned out starter and been setting for a years or more. I had a chore cleaning out the carb. but finally got it running great except for when I start it. I have to turn the kill switch off...
  5. 1998 sportsman starting issues

    Polaris Sportsman
    I have a 1998 Polaris Sportsman 500. I was riding it the other day, and I stopped to check a trail cam. I left it running and got off of it. After about 2 min. it died. When i tried to start it nothing would happen. I pulled it back and checked and I have no spark. What do i do.
Top