Polaris ATV Forum banner

tbap

  1. Tbap help 2005 700 efi

    Polaris Sportsman
    I have an 05 700 and have been dealing with the error code 45 and 41 for awhile. I bought the recommend tbap replacement harness and replaced it. Bike still wouldn't run right. So the I tried spraying the sensor itself with mass air flow sensor cleaner. As soon as I sprayed and put back in the...
  2. Tbap sensor

    ATV Repair and Maintenance
    So I recently got this 2005 Polaris sportsman 700 twin efi not to mention I’m new to the sportsman’s I’m a Honda funatic myself, but anyways when I put it in gear it will take off fast but then hit the rev limiter and won’t really open up for me and it idles like it has a cam in it but the guy...
  3. 2009 Sporty 800 stalling/no power

    ATV Repair and Maintenance
    I have a 2009 Sportsman 800 H.O EFI that all the sudden started running like junk. The machine is bone stock and only basic oil changes have been done to it. I have read a million post about the TPS and TBAP sensor harnesses are awful quality, so I started there and tested everything. I am...
  4. need help 700 efi map sensor wires any one have an 05 700 efi

    2007
    Hello i'm hoping some one can Help me with the wiring and replacement of the map sensor wiring on my 2005 700 efi sportsman. the plug was ripped of by previous owner .. any one have an 05 that could send me a photo of there 2005 700 efi map sensor plug I found all 4 wires 22awg . i have to...
  5. Polaris 700 Efi 2005 map sensor plug missing

    ATV New Members
    Hello i'm hoping some one can Help me with the wiring and replacement of the map sensor wiring on my 2005 700 efi sportsman. the plug was ripped of by previous owner .. I found all 4 wires 22awg . i have to figure out what color goes to what pin on the bosh map sensor and install a new plug...
Top