Polaris ATV Forum banner
voltage
1-11 of 11 Results
  1. ATV Repair and Maintenance
    Hey guys, I went to start my 2016 Sportsman 1000XP the other day and it turned over once then clicked, seemed as though the battery was dead (the screen also said "LO 10.3"), so I put it on the charger over night. In the morning the battery charger said it was fully charged, however when I...
  2. ATV Repair and Maintenance
    There are a lot of comments on this issue, but still have not been able to put a finger on the solution. My 2017 Sportsman EFI 570 just recently started having a flickering display: The backlight is steady on at idle. As soon as I touch the throttle, even slightly, the backlight goes off, and...
  3. ATV Repair and Maintenance
    Hey guys, been going through the forum and using the tips guys have given on this issue but nothing is working for me, have 8.75 draw with key off on both negative cables, took out every fuse and relay 1 by 1, disconnected the voltage regulator and nothing has changed, shut it off from the key...
  4. ATV Repair and Maintenance
    Good after-morning folks! I am certain that others have experienced this before, however it is certainly a first for me. I am cruising a 2003 Polaris Sportsman 700 V-Twin 4x4. I purchased a new battery for my quad as it wouldn't hold a charge, (got it tested and it had dead cells). Shortly...
  5. ATV Gear and Gadgets
    This info might be useful to some of you guys who have heard about, or are interested in a MOSFET regulator upgrade. It's not specific to any make/model, really applies to our universal upgrade kit. Worth a read and checking out for a solid upgrade. RM Stator's MOSFET Voltage Regulator...
  6. ATV Repair and Maintenance
    I have recently acquired a 2006 Sportsman 450. The ECM was replaced on recall in August 2015 (previous owner, confirmed by dealer). As luck would have the NEW one also crapped out. The internal voltage regulator, inside the ecm of course, is not working and battery over charges to 18V at 3000...
  7. ATV Repair and Maintenance
    This is info. on my battery [1998 Xplorer300]. Occassionally, the electric start won't work. There doesn't appear to be a drain on the battery overnight and the voltages look good to me based on info. I read in the forum. Could my problem be it is not run enough or am I missing something...
  8. ATV Repair and Maintenance
    Hi, I have just replaced the battery in my sportsman and have run the voltage test and it is reading 12v or so at idle, however when i drive it is going up to 17 or so. I was told this could be the voltage regulator, however there hasn't been very much driving on this bikes life so that...
  9. ATV New Members
    Hey everyone, I am new to this site but anyway long story short I have an 03 Polaris sportsman 600, I put new stator in new coil and It runs great. However I am seeing the battery light flash when I turn my lights on. I took the seat off and put a metor tester on it and it pulls 12 volts like it...
  10. Polaris Sportsman
    2004 sportsman 500HO seems to be getting fuel, getting 12V to spark plug boot but can't get spark out of 3 different new plugs? Is 12V the right voltage coming out of the boot? tested plugs in lawn mower and getting lots of spark threw it?
  11. ATV Repair and Maintenance
    I have a voltage issue on my 1996 Express 400 2 stroke. Not sure if it is a Voltage regulator or a stator issue. I have changed the voltage regulator before and I have the issue again. I am seeing excessive voltage when the bike is running. At idle I have about 19 volts at the battery...
1-11 of 11 Results
Top