Polaris ATV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
G'day All,

Back again with the never ending saga of the repairs to my quad.

Unfortunately, as I pull it down, other failed parts show up (which is fair enough as she is an old girl).

When I changed the front A arm bushings, a pair of failed wheel bearings and ball joints appeared, as well as a fully ripped CV boot.

I'd already got a full set of boots from the CV man, and have sourced the bearings in town here, so thats OK.

Ordered a pair of ball joints on ebay tonight as well.

The question is:

Is there supposed to be some type of retaining ring in the centre race of the CV joint?

The grease was definitely contaminated, so I've cleaned it out and will add the grease that came with the boot kit.

There seems to be a shallow groove in the middle race that may have held a ring (it looks to shallow to me).

I'm not talking about the C clip on the end of the shaft, but the inside of the race in the joint itself.

Bloody hell, it took some pulling to get it out of the gear housing!

Judging by the rust, dust and bats that came out of there, I'm guessing it had never been removed.

The whole CV is soaking in petrol tonight, and I while reassemble it in the morning if someone can set me staight on this.

Cheers,
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Thanks 4play.

It all went well.

I weighed the exact amount of grease, and the strap tool I bought worked a treat.

Quite pleased with the result.
 
1 - 3 of 3 Posts
Top