Polaris ATV Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
Bought this quad last fall and re-done all the wheel bearings and bushings, new primary and secondary clutches, new struts, new carb boot, new fuel pump, carb kit, and new coil. It probably has high miles, it seems like it should have more power. I have a 98 500 sportsman and I'm pretty sure it has more balls. Any idea what might be my problem? It runs fine(aside from a coolant leak I have now), it just doesn't have the power that I feel it should.

Any help would be greatly appreciated.
 

·
Registered
Joined
·
3,096 Posts
hows the compression ????
 

·
Registered
Joined
·
1,538 Posts
Valve's may need to be adjusted. You mentioned a coolant leak. Is it leaking on to the ground or could it be a blown head gasket?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #6
The primary and secondary are brand new and came already together so I just installed them. Are you thinking I need to tighten the secondary?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
Compression checked ok. I keep hearing about the cam shafts wearing. How would I know if that's the case?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,919 Posts
The 'bad' years for exhaust cams were about 96-99, they had it right by the 02s. What is the top speed of ur 98 vs this 02? My 98 will hit 50+ where as my '10 will hit almost 60 but I back off cuz of the squirrely feeling in dirt roads...haha... :banana:
 

·
Registered
Joined
·
31 Posts
Discussion Starter #9
I can't really compare the speeds cause my 98 has 27s and the 02 stock tires. The 02 just seems to fall flat tight away. I put 2 new clutches on but used the old primary spring. I'm not sure if a pooched spring would cause the effects I'm feeling.


Sent from my iPhone using Tapatalk
 
1 - 9 of 9 Posts
Top