Polaris ATV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
recently our 02 700efi has begun backfiring and losing power under medium to low acceleration. Giving it just a little gas it acts funny, but give it a bit more and it surges forward. also but probably unrelated i have just noticed a small bit of what looks like oil on the bottom, enough to concern me.

my thoughts are that it is getting too much gas and is running rich when at lower engine rpm (wont backfire when idling, have to rev it up high) my other reason for thinking this is that when you rev it up high and just let off the gas, it takes longer than usual to get back to idle, like it has a bit of extra gas to keep the rpms up.

anyone had this issue? trying to find a good jumping off point for fixing this.
 

·
Registered
Joined
·
49 Posts
First off i don't think your machine is an EFI because Polaris didn't start manufacturing the 700efi until 04.And second i really have no idea what would be wrong with it, sorry bout that
 

·
Registered
Joined
·
497 Posts
I doubt it is a rich condition. That usually wont cause backfire but bogging or missing. Backfire is usually an electronic issue with the timing or else some times a dirty or plugged up carb will cause some backfire.
 

·
Registered
Joined
·
78 Posts
lets figure out what you have first. is this for sure EFI or is it Carb? if you have a choke knob it's carb.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
It has a carb. its my fathers machine and im helping him work on it. we got it in a trade and the speedo/odo is busted so i have no idea how many hours it has or when the last maintenance was done on it. might be time to take the carb out and give it a good cleaning up along with checking for fouled spark plugs.
 

·
Registered
Joined
·
4,243 Posts
take side covers off, get some carb cleaner, start it up, spray carb cleaner around carb boot from motor to carb, if it speeds up or slows down, carb boot is cracked , needs replaced, common problem on these machines
 

·
Registered
Joined
·
56 Posts
Sounds like a plugged pilot jet in your carb.
 
1 - 7 of 7 Posts
Top