Polaris ATV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
02 Sportsman 700, it won't start, I have to crank it and crank it until it starts. I have sheared 3-4 flywheel keys. This all started because it was consuming coolant about a year ago. Anything will help at this point! Where is the compression release located?
 

·
Premium Member
Joined
·
20,001 Posts
Welcome to the board! Sounds like a mess!
 

·
Registered
Joined
·
6,903 Posts
did you know, there was a massive recall on your year sportsman 700's for consuming coolant and causing all kinds of problems. at the time, polaris tried to "fix" it by telling dealers only fix the ones that are leaking. there was a large backlash of dealership owners who got pissed because they said if one leaks does it they all will do it and i dont want to deal with a pissed off customer because we are supposed to wait till it happens then fix it now. (our shop mechanic told us this when he went to a dealer meeting a few years back)

anyway, there is a recall kit to fix the coolant consumption. have you checked into this recall for the 700's? if not, i can run your VIN to see whats going on with your machine. just send me a PM if you want me to check
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Thanks for your help!
Yes, I am aware of the coolant leak recall. Last year we replaced the plastic water pump cover with a steel one. The coolant leak is now gone, but the engine is still consuming coolant. We did a top end rebuild less than 50 hours ago. I can't figure out where the coolant is going.
Also, I will check the timing closer to see if I can remedy the very hard starting issue.
Please help me!
 
1 - 6 of 6 Posts
Top