Polaris ATV Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I bought my wife an 03 sportsman 500 ho and while she was riding it started to blow steam out of the cap on the coolant jug.now it won't crank and gives me a red light when I try to start it.

Can anyone point me in the right direction to go about fixing it?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
The motor isn't locked up it just won't turn over every time i hit the start switch a red light comes on and It won't fire don't know if it's a sensor or what
 

·
Registered
Joined
·
378 Posts
Overheating is basically caused by only a few things. The simple things first..... Make sure your Radiator is clear of mud or anything that can clog the fins. A good thorough cleaning is a good thing. By flushing out your system can greatly help removing the heat and check your fan to make sure it comes on when it gets hot. A bad water pump will cause no circulation and it will quickly heat up fast. A few minor maintenance checks could save you some major troubles.

If these check out in a good way, then internal issues, like head, might have to be look into. Until then, Check the basics. Hope all goes well for you.


BTW, Welcome! :)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Ok so I checked everything out put a new plug in and new oil. Oil wasn't milky and my head gasket wasn't blown but it still won't start. Any suggestions?
 

·
Registered
Joined
·
4,243 Posts
Try a new spark plug, maybe do a compression test, test the basics first , needs compression, spark, fuel and air to run.
 

·
Registered
Joined
·
312 Posts
Wouldn't hurt to make sure the back wheels are turning. Just in case the clutch is bound up somehow. I have seen the primary sheaves stick closed which would bind the belt. Sounds silly but worth a quick check.
 
1 - 10 of 10 Posts
Top