Polaris ATV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1 (Edited)
Hello All,
Rear brake on my 04 500 HO started sticking intermittently. Then when it lets go, I have no brake at all and the brake handle bar has no pressure. Back in the garage, the rear brake pad is to hot to touch (along with the rim). Front pads are fine, no heat at all.

This recently started and I've only put a couple mile on the bike since Ive noticed the issue.

Any thoughts on the matter are appreciated.
 

·
Registered
Joined
·
275 Posts
Had the same problem 2 weeks ago. Found one of the piston had stuck in the caliper. Ordered a seal kit than a new caliper as the piston would not come out. Take a screwdriver and push the pads back,the hand brake will move one pad and the pedal will move the other pad. The pressure came back in my lever when the fluid had cooled back down.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
Thanks for the quick reply. So replacing the seal and caliper fixed it? Where did you order your part from? I down loaded this diagram from cheapcycleparts.com, which part should I be looking at?

Again, thanks for the quick reply.
 

·
Registered
Joined
·
5,753 Posts
You should be able to get a complete rebuild kit with all the seals and orings for it. That's the best way to do it since you're already going to be in there.
 

·
Registered
Joined
·
275 Posts
Your year model offers a seal kit (item 17) and a seal kit with piston (item 18). If you can disassemble it before you ordered that would help make the call on which to get. The cheapest place I have found plus the quickest has been hondaeasttoledo.com Ordered my caliper last Mon night so I know they didn't see the ordered till Tue. Received a email on Thursday, it was shipped on Wed. Got home from work on Fri and found it on the porch. Most other places has been at least 2 weeks to get the parts.
 
1 - 5 of 5 Posts
Top