Polaris ATV Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter · #1 ·
my 05 has a high idle and I cant figure out... what should cause this with efi? Maf sensor or somthing? Im unfamiliar with efi atvs this is my first one... it idles so high I have to shut it off to change gears..
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #3 ·
ok wasnt sure i havent even looked at it its been like this since i got it. im doing my full tune up and all fluid change and new belt this weekend. i just wasnt sure if there was a way to do it since i have EFI
 

·
Registered
Joined
·
70 Posts
Discussion Starter · #6 ·
its high enough to keep me from shifting the trans... i just got my pod working tonight so ill see what its at tomorrow...
 

·
Moderator
Joined
·
14,131 Posts
This thread is 7 years old... But... The adjustment on the throttle cable is used to adjust throttle lever free play ONLY. Throttle lever free play should be around 1/16" - 1/8" play before the cable starts to move. It should NOT to be used to adjust idle speed.
If you have an EFI machine idling too fast check for air leaks in the intake boot.
Idle speed/TPS adjustments should only be done on EFI machines using specialized tools and knowledge by a qualified technician... and many dealer techs don't know how lol.
 

·
Registered
Joined
·
8 Posts
This thread is 7 years old... But... The adjustment on the throttle cable is used to adjust throttle lever free play ONLY. Throttle lever free play should be around 1/16" - 1/8" play before the cable starts to move. It should NOT to be used to adjust idle speed.
If you have an EFI machine idling too fast check for air leaks in the intake boot.
Idle speed/TPS adjustments should only be done on EFI machines using specialized tools and knowledge by a qualified technician... and many dealer techs don't know how lol.
 
1 - 9 of 9 Posts
Top