Polaris ATV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
05 polaris 90cc help
just put in new starter, revs up normally in nuetral, in reverse it goes the normal speed, but when switched to forward if wont go?
Motor stays running but does not rev up
any ideas?
Thanks
 

·
Registered
Joined
·
3,417 Posts
I really have no clue. But I will give you some ideas but they might not help. The drive clutch could be broken. It also has a gear selector switch on it. Can you provide more info as to how this occured? Was it working fine other than the starter and a trans problem occured?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
not sure what happened, the kid riding heard a noise, then sat alll winter, then starter stopped working when he decided to start it this spring, does it make sense that it can go in reverse at normal speeed then not go forward?
 

·
Registered
Joined
·
3,417 Posts
not sure what happened, the kid riding heard a noise, then sat alll winter, then starter stopped working when he decided to start it this spring, does it make sense that it can go in reverse at normal speeed then not go forward?
I would remove the belt cover and look at belt and clutches. If not it might be a trans problem. I am sorry I can't help you more. With any luck someone else will help.
 

·
Registered
Joined
·
71 Posts
I'm having this same issue with my 90. Just bought it used knowing it wouldn't start. From a friend. It goes in reverse but when in forward it does but then will lose power and is also really hard to take off. But reverse seems fine. I need help
 
1 - 8 of 8 Posts
Top